summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-07 20:08:49 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-07 20:08:49 +0000
commitaccce44b18ef3495261cea57f8ba4d5f4c726cbc (patch)
tree0983cdabb42da12c848675951fedbcdb7b7891a5 /sys-devel/bison
parentfix dependencies (diff)
downloadgentoo-2-accce44b18ef3495261cea57f8ba4d5f4c726cbc.tar.gz
gentoo-2-accce44b18ef3495261cea57f8ba4d5f4c726cbc.tar.bz2
gentoo-2-accce44b18ef3495261cea57f8ba4d5f4c726cbc.zip
Fix glibc-2.16/gets issue in stable version.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-2.4.3.ebuild5
-rw-r--r--sys-devel/bison/files/bison-2.4.3-no-gets.patch22
3 files changed, 30 insertions, 3 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 365fc5315644..e6798e37d753 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.116 2012/08/24 15:57:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.117 2012/09/07 20:08:49 vapier Exp $
+
+ 07 Sep 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/bison-2.4.3-no-gets.patch, bison-2.4.3.ebuild:
+ Fix glibc-2.16/gets issue in stable version.
24 Aug 2012; Mike Frysinger <vapier@gentoo.org> bison-2.5.1.ebuild,
bison-2.6.1.ebuild, bison-2.6.2.ebuild, bison-2.6.ebuild:
diff --git a/sys-devel/bison/bison-2.4.3.ebuild b/sys-devel/bison/bison-2.4.3.ebuild
index 6ac432a25f2e..dbb99f9c6ca0 100644
--- a/sys-devel/bison/bison-2.4.3.ebuild
+++ b/sys-devel/bison/bison-2.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.3.ebuild,v 1.10 2011/08/17 03:43:40 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.3.ebuild,v 1.11 2012/09/07 20:08:49 vapier Exp $
EAPI="2"
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-uclibc-sched_param-def.patch
+ epatch "${FILESDIR}"/${P}-no-gets.patch
}
src_configure() {
diff --git a/sys-devel/bison/files/bison-2.4.3-no-gets.patch b/sys-devel/bison/files/bison-2.4.3-no-gets.patch
new file mode 100644
index 000000000000..a49a816f4761
--- /dev/null
+++ b/sys-devel/bison/files/bison-2.4.3-no-gets.patch
@@ -0,0 +1,22 @@
+hack until bizon pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@