summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-21 19:33:08 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-21 19:33:08 +0000
commitd54752bb5f4cf35b54ea8ed629c52c563e44f273 (patch)
treefa0068e92e7277ca09f0b55a284fa5e5453e4e2a /sys-devel/binutils-apple
parentVersion bump. (diff)
downloadgentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.tar.gz
gentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.tar.bz2
gentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.zip
Revision bump for usage of Xcode 3.2's ld64. Use Heiko Przybyl's patches to remove the dependency on Apple's libunwind. Port all ebuilds to EAPI=3
(Portage version: 2.2.00.15838-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/binutils-apple')
-rw-r--r--sys-devel/binutils-apple/ChangeLog11
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild11
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild13
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.2-r1.ebuild235
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.2.ebuild25
-rw-r--r--sys-devel/binutils-apple/files/ld64-95.2.12-Makefile26
6 files changed, 289 insertions, 32 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index d66619ca8217..21a43e7c1aa7 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/binutils-apple
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.6 2010/02/12 10:24:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.7 2010/03/21 19:33:06 grobian Exp $
+
+*binutils-apple-3.2-r1 (21 Mar 2010)
+
+ 21 Mar 2010; Fabian Groffen <grobian@gentoo.org>
+ binutils-apple-3.1.1.ebuild, binutils-apple-3.1.2.ebuild,
+ binutils-apple-3.2.ebuild, +binutils-apple-3.2-r1.ebuild,
+ +files/ld64-95.2.12-Makefile:
+ Revision bump for usage of Xcode 3.2's ld64. Use Heiko Przybyl's patches
+ to remove the dependency on Apple's libunwind. Port all ebuilds to EAPI=3
12 Feb 2010; Fabian Groffen <grobian@gentoo.org>
binutils-apple-3.1.1.ebuild, binutils-apple-3.1.2.ebuild,
diff --git a/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild b/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild
index 3b9f144675d8..b777dfee4c2c 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild,v 1.2 2010/02/12 10:24:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.1.ebuild,v 1.3 2010/03/21 19:33:06 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic toolchain-funcs
@@ -48,7 +50,7 @@ fi
S=${WORKDIR}
-unpack_ld64() {
+prepare_ld64() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/Makefile .
@@ -86,9 +88,8 @@ unpack_ld64() {
elog "Deleted $c tests that were bound to fail"
}
-src_unpack() {
- unpack ${A}
- unpack_ld64
+src_prepare() {
+ prepare_ld64
cd "${S}"
epatch "${FILESDIR}"/${P}-as.patch
diff --git a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
index 5b61c45951ec..0f43d23180ee 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.2 2010/02/12 10:24:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.3 2010/03/21 19:33:06 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic toolchain-funcs
@@ -48,7 +50,7 @@ fi
S=${WORKDIR}
-unpack_ld64() {
+prepare_ld64() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/Makefile .
@@ -86,9 +88,8 @@ unpack_ld64() {
elog "Deleted $c tests that were bound to fail"
}
-src_unpack() {
- unpack ${A}
- unpack_ld64
+src_prepare() {
+ prepare_ld64
cd "${S}"/${CCTOOLS}
epatch "${FILESDIR}"/${PN}-3.1.1-as.patch
@@ -146,8 +147,6 @@ install_ld64() {
}
install_cctools() {
- local ED=${ED-${D}}
-
cd "${S}"/${CCTOOLS}
emake install_all_but_headers \
EFITOOLS= \
diff --git a/sys-devel/binutils-apple/binutils-apple-3.2-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-3.2-r1.ebuild
new file mode 100644
index 000000000000..c36246d5704f
--- /dev/null
+++ b/sys-devel/binutils-apple/binutils-apple-3.2-r1.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.2-r1.ebuild,v 1.1 2010/03/21 19:33:06 grobian Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+RESTRICT="test" # the test suite will test what's installed.
+
+# http://lists.apple.com/archives/Darwin-dev/2009/Sep/msg00025.html
+LD64=ld64-95.2.12
+CCTOOLS=cctools-750
+UNWIND=binutils-apple-3.2-unwind-patches-1
+
+DESCRIPTION="Darwin assembler as(1) and static linker ld(1), Xcode Tools 3.2"
+HOMEPAGE="http://www.opensource.apple.com/darwinsource/"
+SRC_URI="http://www.gentoo.org/~grobian/distfiles/${LD64}.tar.gz
+ http://www.gentoo.org/~grobian/distfiles/${CCTOOLS}.tar.gz
+ http://www.gentoo.org/~grobian/distfiles/${UNWIND}.tar.xz"
+
+LICENSE="APSL-2"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+SLOT="0"
+
+DEPEND="sys-devel/binutils-config
+ test? ( >=dev-lang/perl-5.8.8 )"
+RDEPEND="${DEPEND}"
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
+if is_cross ; then
+ SLOT="${CTARGET}"
+else
+ SLOT="0"
+fi
+
+LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${PV}
+INCPATH=${LIBPATH}/include
+DATAPATH=/usr/share/binutils-data/${CTARGET}/${PV}
+if is_cross ; then
+ BINPATH=/usr/${CHOST}/${CTARGET}/binutils-bin/${PV}
+else
+ BINPATH=/usr/${CTARGET}/binutils-bin/${PV}
+fi
+
+S=${WORKDIR}
+
+prepare_ld64() {
+ cd "${S}"/${LD64}/src
+ cp "${FILESDIR}"/${LD64}-Makefile Makefile
+
+ ln -s ../../${CCTOOLS}/include
+ cp "${WORKDIR}"/ld64-unwind/compact_unwind_encoding.h include/mach-o/
+
+ local VER_STR="\"@(#)PROGRAM:ld PROJECT:${LD64} (Gentoo ${PN}-${PVR})\\n\""
+ echo '#undef LTO_SUPPORT' > configure.h
+ echo '' > linker_opts
+ echo "char ldVersionString[] = ${VER_STR};" > version.cpp
+
+ # clean up test suite
+ cd "${S}"/${LD64}/unit-tests/test-cases
+ local c
+
+ # we don't have llvm
+ ((++c)); rm -rf llvm-integration;
+
+ # we don't have dtrace
+ ((++c)); rm -rf dtrace-static-probes-coalescing;
+ ((++c)); rm -rf dtrace-static-probes;
+
+ # a file is missing
+ ((++c)); rm -rf eh-coalescing-r
+
+ # we don't do universal binaries
+ ((++c)); rm -rf blank-stubs;
+
+ # looks like a problem with apple's result-filter.pl
+ ((++c)); rm -rf implicit-common3;
+ ((++c)); rm -rf order_file-ans;
+
+ # TODO no idea what goes wrong here
+ ((++c)); rm -rf dwarf-debug-notes;
+
+ elog "Deleted $c tests that were bound to fail"
+}
+
+src_prepare() {
+ prepare_ld64
+
+ cd "${S}"/${CCTOOLS}
+ epatch "${FILESDIR}"/${PN}-3.1.1-as.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-as-dir.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-ranlib.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-libtool-ranlib.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-nmedit.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-no-headers.patch
+ epatch "${FILESDIR}"/${PN}-3.1.1-no-oss-dir.patch
+ epatch "${FILESDIR}"/${P}-armv7-defines.patch
+
+ cd "${S}"/${LD64}
+ epatch "${FILESDIR}"/${PN}-3.1.1-testsuite.patch
+ epatch "${WORKDIR}"/ld64-unwind/ld64-95.2.12-unlibunwind.patch
+
+ cd "${S}"
+ ebegin "cleaning Makefiles from unwanted CFLAGS"
+ find . -name "Makefile" -print0 | xargs -0 sed \
+ -i \
+ -e 's/ -g / /g' \
+ -e 's/^OFLAG =.*$/OFLAG =/' \
+ -e 's/install -c -s/install/g'
+ eend $?
+
+ # -pg is used and the two are incompatible
+ filter-flags -fomit-frame-pointer
+}
+
+compile_ld64() {
+ cd "${S}"/${LD64}/src
+ # remove antiquated copy that's available on any OSX system and
+ # breaks ld64 compilation
+ mv include/mach-o/dyld.h{,.disable}
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" \
+ || die "emake failed for ld64"
+ use test && emake build_test
+ # restore, it's necessary for cctools' install
+ mv include/mach-o/dyld.h{.disable,}
+}
+
+compile_cctools() {
+ cd "${S}"/${CCTOOLS}
+ emake \
+ LTO= \
+ TRIE= \
+ EFITOOLS= \
+ COMMON_SUBDIRS='libstuff ar misc otool' \
+ SUBDIRS_32= \
+ RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}" \
+ || die "emake failed for the cctools"
+ cd "${S}"/${CCTOOLS}/as
+ emake \
+ BUILD_OBSOLETE_ARCH= \
+ RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}" \
+ || die "emake failed for as"
+}
+
+src_compile() {
+ tc-export CC CXX AR
+ compile_cctools
+ compile_ld64
+}
+
+install_ld64() {
+ exeinto ${BINPATH}
+ doexe "${S}"/${LD64}/src/{ld64,rebase,dyldinfo,unwinddump,ObjectDump}
+ dosym ld64 ${BINPATH}/ld
+ insinto ${DATAPATH}/man/man1
+ doins "${S}"/${LD64}/doc/man/man1/{ld,ld64,rebase}.1
+}
+
+install_cctools() {
+ cd "${S}"/${CCTOOLS}
+ emake install_all_but_headers \
+ EFITOOLS= \
+ COMMON_SUBDIRS='ar misc otool' \
+ SUBDIRS_32= \
+ RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}" \
+ DSTROOT=\"${D}\" \
+ BINDIR=\"${EPREFIX}\"${BINPATH} \
+ LOCBINDIR=\"${EPREFIX}\"${BINPATH} \
+ USRBINDIR=\"${EPREFIX}\"${BINPATH} \
+ LOCLIBDIR=\"${EPREFIX}\"${LIBPATH} \
+ MANDIR=\"${EPREFIX}\"${DATAPATH}/man/
+ cd "${S}"/${CCTOOLS}/as
+ emake install \
+ BUILD_OBSOLETE_ARCH= \
+ DSTROOT=\"${D}\" \
+ USRBINDIR=\"${EPREFIX}\"${BINPATH} \
+ LIBDIR=\"${EPREFIX}\"${LIBPATH}
+
+ cd "${ED}"${BINPATH}
+ insinto ${DATAPATH}/man/man1
+ local skips manpage
+ # ar brings an up-to-date manpage with it
+ skips=( ar )
+ for bin in *; do
+ for skip in ${skips[@]}; do
+ if [[ ${bin} == ${skip} ]]; then
+ continue 2;
+ fi
+ done
+ manpage=${S}/${CCTOOLS}/man/${bin}.1
+ if [[ -f "${manpage}" ]]; then
+ doins "${manpage}"
+ fi
+ done
+ insinto ${DATAPATH}/man/man5
+ doins "${S}"/${CCTOOLS}/man/*.5
+}
+
+src_test() {
+ einfo "Running unit tests"
+ cd "${S}"/${LD64}/unit-tests/test-cases
+ # need host arch, since GNU arch doesn't do what Apple's does
+ tc-export CC CXX
+ perl ../bin/make-recursive.pl \
+ ARCH="$(/usr/bin/arch)" \
+ RELEASEDIR="${S}"/${LD64}/src \
+ | perl ../bin/result-filter.pl
+}
+
+src_install() {
+ install_ld64
+ install_cctools
+
+ cd "${S}"
+ insinto /etc/env.d/binutils
+ cat <<-EOF > env.d
+ TARGET="${CHOST}"
+ VER="${PV}"
+ FAKE_TARGETS="${CHOST}"
+ EOF
+ newins env.d ${CHOST}-${PV}
+}
+
+pkg_postinst() {
+ binutils-config ${CHOST}-${PV}
+}
diff --git a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
index 0fe93303673b..dce382dbe163 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.2.ebuild,v 1.5 2010/02/12 10:24:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.2.ebuild,v 1.6 2010/03/21 19:33:06 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic toolchain-funcs
@@ -52,22 +54,14 @@ fi
S=${WORKDIR}
-unpack_ld64() {
+prepare_ld64() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/Makefile .
-# cd "${S}"/${LD64}
-# cp "${FILESDIR}"/${P}-ld64-Makefile .
-# ln -s ../${CCTOOLS}/include
-# todo: copy compact_unwind_encoding.h
-# cp "${FILESDIR}"/compact_unwind_encoding.h include/mach-o/
-
-# cd src
local VER_STR="\"@(#)PROGRAM:ld PROJECT:${LD64} (Gentoo ${PN}-${PVR})\\n\""
sed -i \
-e '/^#define LTO_SUPPORT 1/s:1:0:' \
ObjectDump.cpp || die
-# other/ObjectDump.cpp || die
echo '#undef LTO_SUPPORT' > configure.h
echo '' > linker_opts
echo "char ldVersionString[] = ${VER_STR};" > version.cpp
@@ -99,13 +93,8 @@ unpack_ld64() {
elog "Deleted $c tests that were bound to fail"
}
-src_unpack() {
- unpack ${A}
- unpack_ld64
-
- # needed to compile trie support
-# cp "${S}"/${LD64}/src/other/prune_trie.h \
-# "${S}"/${CCTOOLS}/include/mach-o
+src_prepare() {
+ prepare_ld64
cd "${S}"/${CCTOOLS}
epatch "${FILESDIR}"/${PN}-3.1.1-as.patch
@@ -176,8 +165,6 @@ install_ld64() {
}
install_cctools() {
- local ED=${ED-${D}}
-
cd "${S}"/${CCTOOLS}
emake install_all_but_headers \
EFITOOLS= \
diff --git a/sys-devel/binutils-apple/files/ld64-95.2.12-Makefile b/sys-devel/binutils-apple/files/ld64-95.2.12-Makefile
new file mode 100644
index 000000000000..bed5d5a1f3e5
--- /dev/null
+++ b/sys-devel/binutils-apple/files/ld64-95.2.12-Makefile
@@ -0,0 +1,26 @@
+CPPFLAGS += -Iinclude -Iabstraction -Ild -Iother -I.
+
+#all: machocheck rebase unwinddump dyldinfo ObjectDump ld64
+all: rebase unwinddump dyldinfo ObjectDump ld64
+
+libprunetrie.a: other/PruneTrie.o other/prune_trie.h
+ $(AR) -r -c libprunetrie.a other/PruneTrie.o
+
+ld64: libprunetrie.a ld/ld.o ld/Options.o ld/debugline.o version.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+rebase: other/rebase.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+dyldinfo: other/dyldinfo.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+unwinddump: other/unwinddump.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+ObjectDump: other/ObjectDump.o ld/debugline.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+machocheck: other/machochecker.o
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+