summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
commit3b400917584ce927f27df4cf507cc5630759f143 (patch)
treec5148d0abb45f9c45a2fd8ad233dcda899e8da92 /sys-devel/bin86
parent*** empty log message *** (diff)
downloadgentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.gz
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.bz2
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.zip
*** empty log message ***
Diffstat (limited to 'sys-devel/bin86')
-rw-r--r--sys-devel/bin86/bin86-0.15.1.ebuild34
-rw-r--r--sys-devel/bin86/files/digest-bin86-0.15.11
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/bin86/bin86-0.15.1.ebuild b/sys-devel/bin86/bin86-0.15.1.ebuild
new file mode 100644
index 000000000000..c7bf7b01594e
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.15.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.15.1.ebuild,v 1.1 2000/08/25 15:10:25 achim Exp $
+
+P=bin86-0.15.1
+A=${P}.tar.gz
+S=${WORKDIR}/bin86
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+SRC_URI="http://www.cix.co.uk/~mayday/${A}"
+HOMEPAGE="http://www.cix.co.uk/~mayday/"
+
+src_compile() {
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/CFLAGS=-O2/CFLAGS=${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin as/as86 as/as86_encap ld/ld86 ld/objdump86 ld/catimage ld/objchop
+ dosym objdump86 /usr/bin/nm86
+ dosym objdump86 /usr/bin/size86
+ doman man/*.1
+ dosym as86_encap.1.gz /usr/man/man1/as86_encap.1.gz
+ dodoc README README-0.4 ChangeLog as/COPYING as/TODO
+}
+
+
diff --git a/sys-devel/bin86/files/digest-bin86-0.15.1 b/sys-devel/bin86/files/digest-bin86-0.15.1
new file mode 100644
index 000000000000..431b3d5f7702
--- /dev/null
+++ b/sys-devel/bin86/files/digest-bin86-0.15.1
@@ -0,0 +1 @@
+MD5 abe3b3b4d6fefaa5137d5b8a889c91de bin86-0.15.1.tar.gz