summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-02-20 01:20:43 +0000
committerMark Guertin <gerk@gentoo.org>2003-02-20 01:20:43 +0000
commitf38f55dd0f1712316229797e9058149ebae5b0c1 (patch)
tree4e403c9ec5d721bccae98a01bbc035b3fad9a3a3 /sys-devel/bc
parentnew ebuild (diff)
downloadgentoo-2-f38f55dd0f1712316229797e9058149ebae5b0c1.tar.gz
gentoo-2-f38f55dd0f1712316229797e9058149ebae5b0c1.tar.bz2
gentoo-2-f38f55dd0f1712316229797e9058149ebae5b0c1.zip
rev bump to close #16043
Diffstat (limited to 'sys-devel/bc')
-rw-r--r--sys-devel/bc/ChangeLog9
-rw-r--r--sys-devel/bc/bc-1.06-r5.ebuild68
-rw-r--r--sys-devel/bc/files/digest-bc-1.06-r51
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-devel/bc/ChangeLog b/sys-devel/bc/ChangeLog
index c5df378c069c..1e0070ea0641 100644
--- a/sys-devel/bc/ChangeLog
+++ b/sys-devel/bc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/bc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.7 2003/02/12 09:13:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.8 2003/02/20 01:20:43 gerk Exp $
+
+*bc-1.06-r5 (19 Feb 2003)
+
+ 19 Feb 2003; Mark Guertin <gerk@gentoo.org> bc-1.06-r5.ebuild
+ files/digest-bc-1.06-r5 :
+ rev bump to close bug #16043, -O2 on ppc causes segfault.
+ Kept stable all arches (only change)
09 Feb 2003; Guy Martin <gmsoft@gentoo.org> bc-1.06-r4.ebuild :
Added hppa to keywords.
diff --git a/sys-devel/bc/bc-1.06-r5.ebuild b/sys-devel/bc/bc-1.06-r5.ebuild
new file mode 100644
index 000000000000..7cf2f0365f03
--- /dev/null
+++ b/sys-devel/bc/bc-1.06-r5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.1 2003/02/20 01:20:43 gerk Exp $
+
+IUSE="readline"
+
+inherit flag-o-matic
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Handy console-based calculator utility"
+SRC_URI="ftp://prep.ai.mit.edu/pub/gnu/bc/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
+
+LICENSE="GPL-2 & LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )"
+DEPEND="$RDEPEND sys-devel/flex"
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+
+ patch -p1 < ${FILESDIR}/bc-1.06-info-fix.diff || die
+ patch -p1 < ${FILESDIR}/bc-1.06-readline42.diff || die
+
+ # Command line arguments for flex changed from the old
+ # 2.5.4 to 2.5.22, so fix configure if we are using the
+ # new flex. Note that flex-2.5.4 prints 'flex version 2.5.4'
+ # and flex-2.5.22 prints 'flex 2.5.22', bug #10546.
+ # <azarah@gentoo.org> (23 Oct 2002)
+ local flmajor="`flex --version | cut -d. -f1`"
+ local flminor="`flex --version | cut -d. -f2`"
+ local flmicro="`flex --version | cut -d. -f3`"
+ if [ "${flmajor/flex* }" -ge 2 -a \
+ "${flminor/flex* }" -ge 5 -a \
+ "${flmicro/flex* }" -ge 22 ]
+ then
+ cd ${S}; cp configure configure.orig
+ sed -e 's:flex -I8:flex -I:g' \
+ configure.orig > configure
+ fi
+}
+
+src_compile() {
+
+ # -O2 causes segafults on ppc with zero backtrace :/
+ use ppc && filter-flags "-O2"
+ local myconf=""
+ use readline && myconf="--with-readline"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ into /usr
+ dobin bc/bc dc/dc
+
+ doinfo doc/*.info
+ doman doc/*.1
+ dodoc AUTHORS COPYING* FAQ NEWS README ChangeLog
+}
+
diff --git a/sys-devel/bc/files/digest-bc-1.06-r5 b/sys-devel/bc/files/digest-bc-1.06-r5
new file mode 100644
index 000000000000..e470cb55f0e4
--- /dev/null
+++ b/sys-devel/bc/files/digest-bc-1.06-r5
@@ -0,0 +1 @@
+MD5 d44b5dddebd8a7a7309aea6c36fda117 bc-1.06.tar.gz 278926