summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-26 18:49:14 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-26 18:49:14 +0000
commitb6eb9b564d872876ae2e3297339e6dd8ed4dc10c (patch)
tree4308b921bc2514829da381130bdcebb16ab02c72 /sys-devel/bc
parentold (diff)
downloadgentoo-2-b6eb9b564d872876ae2e3297339e6dd8ed4dc10c.tar.gz
gentoo-2-b6eb9b564d872876ae2e3297339e6dd8ed4dc10c.tar.bz2
gentoo-2-b6eb9b564d872876ae2e3297339e6dd8ed4dc10c.zip
Fix uninitialized memory usage #349339 by David Flogeras. Convert to EAPI=2 for fun.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bc')
-rw-r--r--sys-devel/bc/ChangeLog9
-rw-r--r--sys-devel/bc/bc-1.06.95-r1.ebuild44
-rw-r--r--sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch13
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/bc/ChangeLog b/sys-devel/bc/ChangeLog
index 2c031cf61336..ffbf4284d9a8 100644
--- a/sys-devel/bc/ChangeLog
+++ b/sys-devel/bc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/bc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.37 2010/02/05 09:55:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/ChangeLog,v 1.38 2010/12/26 18:49:14 vapier Exp $
+
+*bc-1.06.95-r1 (26 Dec 2010)
+
+ 26 Dec 2010; Mike Frysinger <vapier@gentoo.org> +bc-1.06.95-r1.ebuild,
+ +files/bc-1.06.95-void_uninitialized.patch:
+ Fix uninitialized memory usage #349339 by David Flogeras. Convert to
+ EAPI=2 for fun.
05 Feb 2010; Alexis Ballier <aballier@gentoo.org> bc-1.06.95.ebuild:
freebsd-lib does not ship libedit anymore
diff --git a/sys-devel/bc/bc-1.06.95-r1.ebuild b/sys-devel/bc/bc-1.06.95-r1.ebuild
new file mode 100644
index 000000000000..1029ed5a98d0
--- /dev/null
+++ b/sys-devel/bc/bc-1.06.95-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06.95-r1.ebuild,v 1.1 2010/12/26 18:49:14 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Handy console-based calculator utility"
+HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/bc/${P}.tar.bz2
+ mirror://gnu/bc/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="libedit readline static"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-void_uninitialized.patch #349339
+}
+
+src_configure() {
+ local myconf
+ if use readline ; then
+ myconf="--with-readline --without-libedit"
+ elif use libedit ; then
+ myconf="--without-readline --with-libedit"
+ else
+ myconf="--without-readline --without-libedit"
+ fi
+ use static && append-ldflags -static
+ econf ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS FAQ NEWS README ChangeLog
+}
diff --git a/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch b/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch
new file mode 100644
index 000000000000..3304973f89af
--- /dev/null
+++ b/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch
@@ -0,0 +1,13 @@
+http://www.pixelbeat.org/programming/oss_bug_flow.html
+https://bugs.gentoo.org/349339
+
+--- bc/storage.c
++++ bc/storage.c
+@@ -99,6 +99,7 @@
+ {
+ f = &functions[indx];
+ f->f_defined = FALSE;
++ f->f_void = FALSE;
+ f->f_body = (char *) bc_malloc (BC_START_SIZE);
+ f->f_body_size = BC_START_SIZE;
+ f->f_code_size = 0;