summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-30 13:54:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-30 13:54:13 +0000
commit18941b23e099c9b4a04a213676933c502c3b0a5d (patch)
tree5e892d4831f50f71b26d05560d8f8248f5be8333 /sys-devel/automake
parentVersion Bump. Closes bug #77690. (diff)
downloadgentoo-2-18941b23e099c9b4a04a213676933c502c3b0a5d.tar.gz
gentoo-2-18941b23e099c9b4a04a213676933c502c3b0a5d.tar.bz2
gentoo-2-18941b23e099c9b4a04a213676933c502c3b0a5d.zip
Add patches from fedora to fix ccnoco/dirname tests #79505.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/ChangeLog7
-rw-r--r--sys-devel/automake/automake-1.5.ebuild4
-rw-r--r--sys-devel/automake/files/automake-1.5-ccnoco-test.patch31
-rw-r--r--sys-devel/automake/files/automake-1.5-dirnames-test.patch40
4 files changed, 80 insertions, 2 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index dbdd92de3c45..7d6eeb1c7ca7 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/automake
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.67 2005/01/30 13:32:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.68 2005/01/30 13:54:13 vapier Exp $
+
+ 30 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/automake-1.5-ccnoco-test.patch,
+ +files/automake-1.5-dirnames-test.patch, automake-1.5.ebuild:
+ Add patches from fedora to fix ccnoco/dirname tests #79505.
30 Jan 2005; Mike Frysinger <vapier@gentoo.org> automake-1.4_p6.ebuild:
Add a few patches from fedora and dont run error.test since its known to fail
diff --git a/sys-devel/automake/automake-1.5.ebuild b/sys-devel/automake/automake-1.5.ebuild
index b318aa727bc8..14578289b285 100644
--- a/sys-devel/automake/automake-1.5.ebuild
+++ b/sys-devel/automake/automake-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.15 2005/01/30 13:35:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.16 2005/01/30 13:54:13 vapier Exp $
inherit eutils gnuconfig
@@ -23,6 +23,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-target_hook.patch
epatch ${FILESDIR}/${P}-slot.patch
+ epatch ${FILESDIR}/${P}-ccnoco-test.patch
+ epatch ${FILESDIR}/${P}-dirnames-test.patch
sed -i \
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
diff --git a/sys-devel/automake/files/automake-1.5-ccnoco-test.patch b/sys-devel/automake/files/automake-1.5-ccnoco-test.patch
new file mode 100644
index 000000000000..086af020fd79
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.5-ccnoco-test.patch
@@ -0,0 +1,31 @@
+diff -u automake-1.5/tests/ccnoco.test automake-1.6.3/tests/ccnoco.test
+--- automake-1.5/tests/ccnoco.test 2003-06-07 06:34:18.000000000 +0900
++++ automake-1.6.3/tests/ccnoco.test 2003-06-07 06:34:18.000000000 +0900
+@@ -39,7 +39,6 @@
+ }
+ END
+
+-$needs_autoconf
+ gcc -v || exit 77
+
+ cat > Mycomp << 'END'
+@@ -51,7 +50,7 @@
+ ;;
+ esac
+
+-exec gcc ${1+"$@"}
++exec gcc "$@"
+ END
+
+ chmod +x Mycomp
+@@ -59,6 +58,10 @@
+ set -e
+
+
++# Ignore user CFLAGS.
++CFLAGS=
++export CFLAGS
++
+ for conf in configure.1 configure.3; do
+ cp $conf configure.in
+
diff --git a/sys-devel/automake/files/automake-1.5-dirnames-test.patch b/sys-devel/automake/files/automake-1.5-dirnames-test.patch
new file mode 100644
index 000000000000..7da9ccaa1444
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.5-dirnames-test.patch
@@ -0,0 +1,40 @@
+diff -u automake-1.5/tests/dirname.test automake-1.6.3/tests/dirname.test
+--- automake-1.5/tests/dirname.test 2003-04-25 15:44:56.000000000 +0900
++++ automake-1.6.3/tests/dirname.test 2003-04-25 15:44:56.000000000 +0900
+@@ -5,7 +5,7 @@
+ . $srcdir/defs || exit 1
+
+ cat > configure.in << 'END'
+-AC_PLAIN_SCRIPT
++AC_INIT
+ echo "1 /a/path/to/a/file = _AM_DIRNAME([/a/path/to/a/file])"
+ echo "2 another/path/to/a/file = _AM_DIRNAME([another/path/to/a/file])"
+ echo "3 file = _AM_DIRNAME([file])"
+@@ -15,17 +15,13 @@
+ echo "7 /file = _AM_DIRNAME([/file])"
+ END
+
+-# Fail gracefully if no autoconf.
+-$needs_autoconf
+-
+ $ACLOCAL || exit 1
+-$AUTOCONF || exit 1
+-
+-# fail gracefully if autoconf didn't support AC_PLAIN_SCRIPT, because it won't
+-# support our regexps anyhow
+-test -s configure || exit 77
++# fail gracefully if autoconf didn't support support our regexps anyhow
++$AUTOCONF || exit 77
+
+-$SHELL ./configure >got || exit 1
++# Use --quiet otherwise unwelcome messages like "loading site script"
++# would cause a failure.
++./configure --quiet >got || exit 1
+
+ cat >wanted <<EOF
+ 1 /a/path/to/a/file = /a/path/to/a
+@@ -40,4 +36,3 @@
+ diff wanted got || exit 1
+
+ exit 0
+-