summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-08 18:02:51 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-08 18:02:51 +0000
commit0354cc2108d291297add2833f4dccd242b997826 (patch)
treeb0b783203a5df0a8f1ad790b2325c45ba40661f1 /sys-devel/automake
parentx86 stable per bug 362185 (diff)
downloadgentoo-2-0354cc2108d291297add2833f4dccd242b997826.tar.gz
gentoo-2-0354cc2108d291297add2833f4dccd242b997826.tar.bz2
gentoo-2-0354cc2108d291297add2833f4dccd242b997826.zip
Add fix by Petteri Räty for java handling #362323.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/automake')
-rw-r--r--sys-devel/automake/ChangeLog10
-rw-r--r--sys-devel/automake/automake-1.11.1-r1.ebuild79
-rw-r--r--sys-devel/automake/files/automake-1.11.1-check-java.patch27
3 files changed, 114 insertions, 2 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index c22e50eff488..390b3ae05523 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/automake
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.151 2010/05/31 19:20:31 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.152 2011/04/08 18:02:51 vapier Exp $
+
+*automake-1.11.1-r1 (08 Apr 2011)
+
+ 08 Apr 2011; Mike Frysinger <vapier@gentoo.org> +automake-1.11.1-r1.ebuild,
+ +files/automake-1.11.1-check-java.patch:
+ Add fix by Petteri Räty for java handling #362323.
31 May 2010; Joseph Jezak <josejx@gentoo.org> automake-1.11.1.ebuild:
Marked ppc64 stable for bug #295947.
diff --git a/sys-devel/automake/automake-1.11.1-r1.ebuild b/sys-devel/automake/automake-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..c46b4e73e121
--- /dev/null
+++ b/sys-devel/automake/automake-1.11.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11.1-r1.ebuild,v 1.1 2011/04/08 18:02:51 vapier Exp $
+
+inherit eutils versionator
+
+if [[ ${PV/_beta} == ${PV} ]]; then
+ MY_P=${P}
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+else
+ MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_P="${PN}-${MY_PV}"
+
+ # Alpha/beta releases are not distributed on the usual mirrors.
+ SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.bz2"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://sources.redhat.com/automake/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-3-r2
+ >=sys-devel/autoconf-2.62
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ chmod a+rx tests/*.test
+ sed -i \
+ -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die "sed failed"
+ mv doc/automake{,${SLOT}}.texi
+ sed -i \
+ -e "s:automake.info:automake${SLOT}.info:" \
+ -e "s:automake.texi:automake${SLOT}.texi:" \
+ doc/Makefile.in || die "sed on Makefile.in failed"
+ epatch "${FILESDIR}"/${P}-check-java.patch #362323
+ export WANT_AUTOCONF=2.5
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+
+ local x
+ for x in aclocal automake; do
+ help2man "perl -Ilib ${x}" > doc/${x}-${SLOT}.1
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ dodoc NEWS README THANKS TODO AUTHORS ChangeLog
+
+ rm \
+ "${D}"/usr/bin/{aclocal,automake} \
+ "${D}"/usr/share/man/man1/{aclocal,automake}.1
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}
diff --git a/sys-devel/automake/files/automake-1.11.1-check-java.patch b/sys-devel/automake/files/automake-1.11.1-check-java.patch
new file mode 100644
index 000000000000..861a5f6c37dc
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.11.1-check-java.patch
@@ -0,0 +1,27 @@
+should be in upstream git now
+
+https://bugs.gentoo.org/362323
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=8234
+
+diff --git a/automake.in b/automake.in
+index d74730d..a8ec749 100755
+--- a/automake.in
++++ b/automake.in
+@@ -5121,8 +5121,14 @@ sub handle_java
+ $dir = $curs;
+ }
+
+-
+- push (@all, 'class' . $dir . '.stamp');
++ if ($dir eq 'check')
++ {
++ push (@check, "class$dir.stamp");
++ }
++ else
++ {
++ push (@all, "class$dir.stamp");
++ }
+ }
+
+
+