summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
commit1a4033385730a6c617730dafe6f04d4e40805267 (patch)
treee13dc759ed921b31f6e5da3073aed69f012a165e /sys-devel/automake/files
parentChanged GPL to GPL-2 in LICENSE (diff)
downloadgentoo-2-1a4033385730a6c617730dafe6f04d4e40805267.tar.gz
gentoo-2-1a4033385730a6c617730dafe6f04d4e40805267.tar.bz2
gentoo-2-1a4033385730a6c617730dafe6f04d4e40805267.zip
wrapper updates
Diffstat (limited to 'sys-devel/automake/files')
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.629
1 files changed, 23 insertions, 6 deletions
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.6 b/sys-devel/automake/files/am-wrapper.pl-1.6
index 4aa266cc6d13..bb397c72f114 100644
--- a/sys-devel/automake/files/am-wrapper.pl-1.6
+++ b/sys-devel/automake/files/am-wrapper.pl-1.6
@@ -17,14 +17,24 @@
#
# - defaults to automake-1.4
# - runs automake-1.6x if it exists and...
-# - envvar WANT_AUTOMAKE_1_6 is set to `1'
+# - envvar WANT_AUTOMAKE_1_6 is set to `1'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6x
# - runs automake-1.5x if it exists and...
-# - envvar WANT_AUTOMAKE_1_5 is set to `1'
-# or - configure.ac is present
-# or - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# - envvar WANT_AUTOMAKE_1_5 is set to `1'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.5x or superior, which
+# specifically needs automake-1.5x
#
-
#use MDK::Common;
sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
@@ -33,14 +43,21 @@ my $binary = "$0-1.4";
my $binary_new = "$0-1.5x";
my $binary_vnew = "$0-1.6x";
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
if (!$ENV{WANT_AUTOMAKE_1_4}) {
if (-x $binary_vnew # user may not have _1_6
- && ($ENV{WANT_AUTOMAKE_1_6}) ) {
+ && ($ENV{WANT_AUTOMAKE_1_6}
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6')) {
$binary = $binary_vnew;
} elsif (-x $binary_new # user may have only 2.13
&& ($ENV{WANT_AUTOMAKE_1_5}
|| -r 'configure.ac'
|| (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
|| (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOMAKE_1_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;