summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-02 10:18:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-02 10:18:43 +0000
commit017433f57e6931938cf560c69c1fff99c5b25cec (patch)
tree8982fbd3682ab733c991b8360565470f623bbff5 /sys-devel/autogen
parentVersion bump. (diff)
downloadgentoo-2-017433f57e6931938cf560c69c1fff99c5b25cec.tar.gz
gentoo-2-017433f57e6931938cf560c69c1fff99c5b25cec.tar.bz2
gentoo-2-017433f57e6931938cf560c69c1fff99c5b25cec.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/ChangeLog7
-rw-r--r--sys-devel/autogen/autogen-5.18.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-devel/autogen/ChangeLog b/sys-devel/autogen/ChangeLog
index 66eb0da960bc..a2fda65564d7 100644
--- a/sys-devel/autogen/ChangeLog
+++ b/sys-devel/autogen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autogen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.97 2013/05/27 09:56:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.98 2013/12/02 10:18:43 radhermit Exp $
+
+*autogen-5.18.1 (02 Dec 2013)
+
+ 02 Dec 2013; Tim Harder <radhermit@gentoo.org> +autogen-5.18.1.ebuild:
+ Version bump.
*autogen-5.17.4 (27 May 2013)
diff --git a/sys-devel/autogen/autogen-5.18.1.ebuild b/sys-devel/autogen/autogen-5.18.1.ebuild
new file mode 100644
index 000000000000..2114da6f81be
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.18.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.18.1.ebuild,v 1.1 2013/12/02 10:18:43 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="http://www.gnu.org/software/autogen/"
+SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libopts static-libs"
+
+RDEPEND=">=dev-scheme/guile-1.8
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}