summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-02 20:11:53 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-02 20:11:53 +0000
commitb1ebd7a0c59dad25f2a434a9f02817b50ce4ea78 (patch)
tree816296c3c093609b0807d80713aba5da4d3a8a85 /sys-devel/autoconf
parentold (diff)
downloadgentoo-2-b1ebd7a0c59dad25f2a434a9f02817b50ce4ea78.tar.gz
gentoo-2-b1ebd7a0c59dad25f2a434a9f02817b50ce4ea78.tar.bz2
gentoo-2-b1ebd7a0c59dad25f2a434a9f02817b50ce4ea78.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog7
-rw-r--r--sys-devel/autoconf/autoconf-2.67.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 14ca2f3bf111..4ae3a79730c7 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.145 2010/07/05 09:57:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.146 2010/08/02 20:11:53 vapier Exp $
+
+*autoconf-2.67 (02 Aug 2010)
+
+ 02 Aug 2010; Mike Frysinger <vapier@gentoo.org> +autoconf-2.67.ebuild:
+ Version bump.
05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> autoconf-2.65.ebuild:
ppc64 stable wrt #311967
diff --git a/sys-devel/autoconf/autoconf-2.67.ebuild b/sys-devel/autoconf/autoconf-2.67.ebuild
new file mode 100644
index 000000000000..9bf70a80c509
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.67.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.67.ebuild,v 1.1 2010/08/02 20:11:53 vapier Exp $
+
+EAPI="2"
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="2.5"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-9"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_configure() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}