summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-10 04:31:40 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-10 04:31:40 +0000
commit5ef42ea593ee7e23eac8a2be03680bcb68f91c2c (patch)
treea149b6be01b3d5899c7ff357b065b5881e7496f1 /sys-devel/autoconf
parentFix building when ncurses is built with USE=-ncurses #217046. (diff)
downloadgentoo-2-5ef42ea593ee7e23eac8a2be03680bcb68f91c2c.tar.gz
gentoo-2-5ef42ea593ee7e23eac8a2be03680bcb68f91c2c.tar.bz2
gentoo-2-5ef42ea593ee7e23eac8a2be03680bcb68f91c2c.zip
Version bump.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog9
-rw-r--r--sys-devel/autoconf/autoconf-2.62.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 6296b488ce80..ca29d1e0205a 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autoconf
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.110 2007/11/02 06:30:50 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.111 2008/04/10 04:31:40 vapier Exp $
+
+*autoconf-2.62 (10 Apr 2008)
+
+ 10 Apr 2008; Mike Frysinger <vapier@gentoo.org> +autoconf-2.62.ebuild:
+ Version bump.
*autoconf-9999 (02 Nov 2007)
diff --git a/sys-devel/autoconf/autoconf-2.62.ebuild b/sys-devel/autoconf/autoconf-2.62.ebuild
new file mode 100644
index 000000000000..0ce9189faa4f
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.62.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.62.ebuild,v 1.1 2008/04/10 04:31:40 vapier Exp $
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-4-r2"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_compile() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+ # From configure output:
+ # Parallel builds via `make -jN' do not work.
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}