summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-13 14:06:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-13 14:06:45 +0000
commitff73dad79eabd6e1a877cfac11b256bce07b4da6 (patch)
tree402337c2538c30b962ebd1024b0c50a237c3a303 /sys-cluster
parentInclude experimental patch from upstream for linking with gold - masked for now (diff)
downloadgentoo-2-ff73dad79eabd6e1a877cfac11b256bce07b4da6.tar.gz
gentoo-2-ff73dad79eabd6e1a877cfac11b256bce07b4da6.tar.bz2
gentoo-2-ff73dad79eabd6e1a877cfac11b256bce07b4da6.zip
Re-license init script as stated by Pavel in bug #426158. Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/gearmand/ChangeLog8
-rw-r--r--sys-cluster/gearmand/files/gearmand.init.d.22
-rw-r--r--sys-cluster/gearmand/gearmand-0.34.ebuild89
3 files changed, 97 insertions, 2 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 7858fe88cae0..74febd2fbe80 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/gearmand
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.16 2012/06/24 21:20:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.17 2012/07/13 14:06:45 flameeyes Exp $
+
+*gearmand-0.34 (13 Jul 2012)
+
+ 13 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +gearmand-0.34.ebuild,
+ files/gearmand.init.d.2:
+ Re-license init script as stated by Pavel in bug #426158. Version bump.
24 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata, helps my own bug templating script.
diff --git a/sys-cluster/gearmand/files/gearmand.init.d.2 b/sys-cluster/gearmand/files/gearmand.init.d.2
index a3d3b3375824..bf7d681c90e8 100644
--- a/sys-cluster/gearmand/files/gearmand.init.d.2
+++ b/sys-cluster/gearmand/files/gearmand.init.d.2
@@ -1,6 +1,6 @@
#!/sbin/runscript
# Copyright 2009-2012 Pavel Stratil, senbonzakura.eu
-# Distributed under the terms of the GNU General Public License v2
+# Distributed under the terms of the MIT license
pidfile=/var/run/gearmand/gearmand.pid
command=/usr/sbin/gearmand
diff --git a/sys-cluster/gearmand/gearmand-0.34.ebuild b/sys-cluster/gearmand/gearmand-0.34.ebuild
new file mode 100644
index 000000000000..f3b0cbcb3919
--- /dev/null
+++ b/sys-cluster/gearmand/gearmand-0.34.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.34.ebuild,v 1.1 2012/07/13 14:06:44 flameeyes Exp $
+
+EAPI=4
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="Generic framework to farm out work to other machines"
+HOMEPAGE="http://www.gearman.org/"
+SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
+
+RDEPEND="dev-libs/libevent
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ tcmalloc? ( dev-util/google-perftools )
+ memcache? ( >=dev-libs/libmemcached-0.47 )
+ drizzle? ( dev-db/drizzle )
+ sqlite? ( dev-db/sqlite:3 )
+ tokyocabinet? ( dev-db/tokyocabinet )
+ postgres? ( >=dev-db/postgresql-base-9.0 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewuser gearmand -1 -1 /dev/null nogroup
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # Don't ever use --enable-assert since configure.ac is broken, and
+ # only does --disable-assert correctly.
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-cppflags -DDEBUG
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ $(use_enable tcmalloc) \
+ $(use_enable memcache libmemcached) \
+ $(use_enable drizzle libdrizzle) \
+ $(use_with sqlite sqlite3) \
+ $(use_enable tokyocabinet libtokyocabinet) \
+ $(use_enable postgres libpq)
+}
+
+src_test() {
+ # Since libtool is stupid and doesn't discard /usr/lib64 from the
+ # load path, we'd end up testing against the installed copy of
+ # gearmand (bad).
+ #
+ # We thus cheat and "fix" the scripts by hand.
+ sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
+ || die "test fixing failed"
+
+ emake check
+}
+
+DOCS=( README AUTHORS ChangeLog )
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/gearmand.init.d.2 gearmand
+ newconfd "${FILESDIR}"/gearmand.conf.d gearmand
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "Unless you set the PERSISTENT_TABLE option in"
+ elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
+ elog "If such table doesn't exist, Gearmand will create it for you"
+ elog ""
+}