summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Smirnov <civil@gentoo.org>2015-03-11 08:00:14 +0000
committerVladimir Smirnov <civil@gentoo.org>2015-03-11 08:00:14 +0000
commite4e9a66ec731f43e964174b6674a50f2f9948d82 (patch)
tree18fe3efbde20054be846d6aa07d9418b6ae574f8 /sys-cluster
parentVersion bump, thanks to Andreis Vinogradovs (diff)
downloadgentoo-2-e4e9a66ec731f43e964174b6674a50f2f9948d82.tar.gz
gentoo-2-e4e9a66ec731f43e964174b6674a50f2f9948d82.tar.bz2
gentoo-2-e4e9a66ec731f43e964174b6674a50f2f9948d82.zip
Version bump, thanks to Andreis Vinogradovs
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xC47990C2)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/ChangeLog7
-rw-r--r--sys-cluster/ploop/ploop-1.12.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index d373ab25cad8..228e32f99083 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.33 2015/01/26 09:39:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.34 2015/03/11 08:00:14 civil Exp $
+
+*ploop-1.12.2 (11 Mar 2015)
+
+ 11 Mar 2015; Vladimir Smirnov <civil@gentoo.org> +ploop-1.12.2.ebuild:
+ Version bump, thanks to Andreis Vinogradovs
26 Jan 2015; Agostino Sarubbo <ago@gentoo.org> ploop-1.12.ebuild:
Stable for x86, wrt bug #535668
diff --git a/sys-cluster/ploop/ploop-1.12.2.ebuild b/sys-cluster/ploop/ploop-1.12.2.ebuild
new file mode 100644
index 000000000000..7ed7ed3af796
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.12.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.12.2.ebuild,v 1.1 2015/03/11 08:00:14 civil Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="
+ dev-libs/libxml2
+ virtual/pkgconfig
+ "
+
+RDEPEND="dev-libs/libxml2
+ !<sys-cluster/vzctl-4.5
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils
+ "
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+}