summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-04-02 22:30:09 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-04-02 22:30:09 +0000
commitd40ffa57a4f8fac667750ef830d6983c7071fa58 (patch)
tree3f4ceba501077795407253c4a0176a238581f38b /sys-cluster
parentNow installs to /usr/share/pvm3 instead of /usr/local/pvm3. This closes #3306... (diff)
downloadgentoo-2-d40ffa57a4f8fac667750ef830d6983c7071fa58.tar.gz
gentoo-2-d40ffa57a4f8fac667750ef830d6983c7071fa58.tar.bz2
gentoo-2-d40ffa57a4f8fac667750ef830d6983c7071fa58.zip
Add MPICH_CONFIGURE_OPTS variable for customization (#38207).
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich/ChangeLog5
-rw-r--r--sys-cluster/mpich/mpich-1.2.5.2.ebuild16
2 files changed, 19 insertions, 2 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index 349b291fb80f..31cb9bfd228f 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.12 2004/04/02 21:43:26 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.13 2004/04/02 22:30:09 spyderous Exp $
+
+ 02 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; mpich-1.2.5.2.ebuild:
+ Add MPICH_CONFIGURE_OPTS variable for customization (#38207).
02 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; mpich-1.2.5.2.ebuild:
lam-mpi changed categories a while back, but RDEPEND was never changed to
diff --git a/sys-cluster/mpich/mpich-1.2.5.2.ebuild b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
index 6a85155bf21b..c8a27850429e 100644
--- a/sys-cluster/mpich/mpich-1.2.5.2.ebuild
+++ b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.5 2004/04/02 21:43:26 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.6 2004/04/02 22:30:09 spyderous Exp $
+
+# Set the MPICH_CONFIGURE_OPTS environment variable to change the signal
+# mpich listens on or any other custom options (#38207).
+# The default USR1 conflicts with pthreads. Options include SIGUSR2 and SIGBUS.
+# For example: MPICH_CONFIGURE_OPTS="--with-device=ch_p4:-listener_sig=SIGBUS"
DESCRIPTION="MPICH - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
@@ -17,6 +22,12 @@ RDEPEND="${DEPEND}
!crypt? ( net-misc/netkit-rsh )
!sys-cluster/lam-mpi"
+pkg_setup() {
+ if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then
+ einfo "Custom configure options are ${MPICH_CONFIGURE_OPTS}."
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,7 +45,10 @@ src_compile() {
export RSHCOMMAND
+ local myconf="${myconf} ${MPICH_CONFIGURE_OPTS}"
+
./configure \
+ ${myconf} \
--mandir=/usr/share/man \
--prefix=/usr || die
make || die