summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-06-13 20:38:47 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-06-13 20:38:47 +0000
commitc503e6ba8dcd1030431a5f7cf1dae8d489b99e21 (patch)
treef465906d7fdbf574583e8206f28c958daf192e09 /sys-cluster
parentUpdated 1.3.6 version icluding fixes for bug #273960 #246843. Some (diff)
downloadgentoo-2-c503e6ba8dcd1030431a5f7cf1dae8d489b99e21.tar.gz
gentoo-2-c503e6ba8dcd1030431a5f7cf1dae8d489b99e21.tar.bz2
gentoo-2-c503e6ba8dcd1030431a5f7cf1dae8d489b99e21.zip
Bump sys-cluster/hpl-2.0, #262204
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpl/ChangeLog9
-rw-r--r--sys-cluster/hpl/hpl-2.0.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index 5015c7e62ef3..c6e0c4f24603 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/hpl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.11 2007/04/26 06:04:44 dberkholz Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.12 2009/06/13 20:38:47 jsbronder Exp $
+
+*hpl-2.0 (13 Jun 2009)
+
+ 13 Jun 2009; Justin Bronder <jsbronder@gentoo.org> +hpl-2.0.ebuild:
+ Version bump, #262204
26 Apr 2007; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Update for cluster herd split to hp-cluster and ha-cluster.
diff --git a/sys-cluster/hpl/hpl-2.0.ebuild b/sys-cluster/hpl/hpl-2.0.ebuild
new file mode 100644
index 000000000000..9d3c2c4645a6
--- /dev/null
+++ b/sys-cluster/hpl/hpl-2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0.ebuild,v 1.1 2009/06/13 20:38:47 jsbronder Exp $
+
+inherit eutils
+
+DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl.tgz"
+LICENSE="HPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+DEPEND="virtual/mpi
+ virtual/blas
+ virtual/lapack"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
+ sed -i \
+ -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
+ -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
+ -e '/^MPdir\>/s,= .*,=,' \
+ -e '/^MPlib\>/s,= .*,=,' \
+ -e "/^LAlib\>/s,= .*,= /usr/$(get_libdir)/libblas.so /usr/$(get_libdir)/liblapack.so," \
+ -e '/^LINKER\>/s,= .*,= mpicc,' \
+ -e '/^CC\>/s,= .*,= mpicc,' \
+ Make.gentoo_hpl_fblas_x86
+}
+
+src_compile() {
+ # do NOT use emake here
+ HOME=${WORKDIR} make arch=gentoo_hpl_fblas_x86 || die "Failed to build"
+}
+
+src_install() {
+ doman man/man3/*.3
+ dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
+ dobin bin/gentoo_hpl_fblas_x86/xhpl || die "Failed to install bins"
+ insinto /usr/share/hpl
+ doins bin/gentoo_hpl_fblas_x86/HPL.dat || die "Failed to install HPL parameters"
+ dohtml -r www/*
+ dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die "Failed to install lib"
+}
+
+pkg_postinst() {
+ einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory first!"
+ einfo "For mpich, run linpack by executing this in your working directory"
+ einfo "\"mpirun -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+ einfo "Other methods are needed lam-mpi etc."
+}