summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-02-12 03:05:39 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-02-12 03:05:39 +0000
commitc3c46dc5279fba48514de5620ca9d749348e6cef (patch)
treeefd9b1a94c207e56f53dcf1eaf4b11e67101e4d7 /sys-cluster
parentVersion bump (diff)
downloadgentoo-2-c3c46dc5279fba48514de5620ca9d749348e6cef.tar.gz
gentoo-2-c3c46dc5279fba48514de5620ca9d749348e6cef.tar.bz2
gentoo-2-c3c46dc5279fba48514de5620ca9d749348e6cef.zip
Fix the mpich2 pkgconfig file, #257921. Mark patchses to be sent upstream.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog6
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.8-pkgconfig.patch17
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.8.ebuild9
3 files changed, 30 insertions, 2 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 98cf4d1d964f..24fe98eddff6 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.33 2009/01/21 18:56:27 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.34 2009/02/12 03:05:39 jsbronder Exp $
+
+ 12 Feb 2009; Justin Bronder <jsbronder@gentoo.org>
+ +files/mpich2-1.0.8-pkgconfig.patch, mpich2-1.0.8.ebuild:
+ Fix the mpich2 pkgconfig file, #257921. Mark patchses to be sent upstream.
21 Jan 2009; Justin Bronder <jsbronder@gentoo.org> mpich2-1.0.8.ebuild:
sys-cluster/mpich-1.0.8 bugfixes, no revbump. Fix some doc file locations
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.8-pkgconfig.patch b/sys-cluster/mpich2/files/mpich2-1.0.8-pkgconfig.patch
new file mode 100644
index 000000000000..1d3a456bdd26
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.0.8-pkgconfig.patch
@@ -0,0 +1,17 @@
+--- a/mpich2-1.0.8/src/pkgconfig/mpich2-ch3.pc.in 2008-11-04 20:36:38.931970012 -0500
++++ b/mpich2-1.0.8/src/pkgconfig/mpich2-ch3.pc.in 2009-02-11 21:39:00.279871039 -0500
+@@ -1,8 +1,12 @@
+ # this gives access to the mpich2 header files
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
+
+ Name: mpich2
+ Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
+ Version: @VERSION@
+ Requires:
+-Libs: -L@libdir@ -lmpich -lmpichcxx @LIBS@
+-Cflags: @CFLAGS@ -I@includedir@ -DMPICH_IGNORE_CXX_SEEK
++Libs: -L${libdir} -lmpich -lmpichcxx @LIBS@
++Cflags: @CFLAGS@ -I${includedir} -DMPICH_IGNORE_CXX_SEEK
diff --git a/sys-cluster/mpich2/mpich2-1.0.8.ebuild b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
index 691439b441bb..71731421c900 100644
--- a/sys-cluster/mpich2/mpich2-1.0.8.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.3 2009/01/21 18:56:27 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.4 2009/02/12 03:05:39 jsbronder Exp $
EAPI=1
inherit python eutils fortran
@@ -71,9 +71,11 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-site-packages-py.patch
# Respect the env var MPD_CONF_FILE
+ # TODO: Send upstream
epatch "${FILESDIR}"/${P}-mpdconf-env.patch
# Fix gforker instal-alt
+ # TODO: Send upstream
epatch "${FILESDIR}"/${P}-gforker-install-alt-fix.patch
# We need f90 to include the directory with mods, and to
@@ -85,8 +87,13 @@ src_unpack() {
$(find ./test/ -name 'Makefile.in') || die
# 254167, I'm pretty sure they meant srcdir in the path to remove files.
+ # TODO: Send upstream
sed -i 's:scrdir:srcdir:g' "${S}"/src/pm/mpd/Makefile.in || die
+ # #257821, fix the pkgconfig file.
+ # TODO: Send upstream
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+
if ! use romio; then
# These tests in errhan/ rely on MPI::File ...which is in romio
echo "" > test/mpi/errors/cxx/errhan/testlist