summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-10-29 16:44:23 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-10-29 16:44:23 +0000
commitbf04eed6d2f80fc7643fdf850d648a1b5a8e8548 (patch)
treeb0758aa2d883f4ca2a29f4fa8bb1658b7902e531 /sys-cluster
parentUse virtual for argparse. (diff)
downloadgentoo-2-bf04eed6d2f80fc7643fdf850d648a1b5a8e8548.tar.gz
gentoo-2-bf04eed6d2f80fc7643fdf850d648a1b5a8e8548.tar.bz2
gentoo-2-bf04eed6d2f80fc7643fdf850d648a1b5a8e8548.zip
Fix heartbeat init script fix #438672
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/heartbeat/ChangeLog8
-rw-r--r--sys-cluster/heartbeat/files/heartbeat-init6
-rw-r--r--sys-cluster/heartbeat/heartbeat-3.0.5-r1.ebuild86
3 files changed, 97 insertions, 3 deletions
diff --git a/sys-cluster/heartbeat/ChangeLog b/sys-cluster/heartbeat/ChangeLog
index e3e0ef71a623..bde49902cde5 100644
--- a/sys-cluster/heartbeat/ChangeLog
+++ b/sys-cluster/heartbeat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/heartbeat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/ChangeLog,v 1.103 2012/05/04 07:20:30 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/ChangeLog,v 1.104 2012/10/29 16:44:23 ultrabug Exp $
+
+*heartbeat-3.0.5-r1 (29 Oct 2012)
+
+ 29 Oct 2012; Ultrabug <ultrabug@gentoo.org> +heartbeat-3.0.5-r1.ebuild,
+ files/heartbeat-init:
+ Fix init script vital directory creation wrt #438672 thx to Petric Frank.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> heartbeat-3.0.5.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sys-cluster/heartbeat/files/heartbeat-init b/sys-cluster/heartbeat/files/heartbeat-init
index 5a81a21ce818..1de6fc5862e4 100644
--- a/sys-cluster/heartbeat/files/heartbeat-init
+++ b/sys-cluster/heartbeat/files/heartbeat-init
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/files/heartbeat-init,v 1.7 2007/03/01 00:48:11 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/files/heartbeat-init,v 1.8 2012/10/29 16:44:23 ultrabug Exp $
HA_DIR=/etc/ha.d
. $HA_DIR/shellfuncs
@@ -26,6 +26,8 @@ RunStartStop() {
}
start() {
+ checkpath -q -d -m 0755 -o root:root /var/run/heartbeat
+
ebegin "Starting heartbeat"
. $HA_DIR/shellfuncs
diff --git a/sys-cluster/heartbeat/heartbeat-3.0.5-r1.ebuild b/sys-cluster/heartbeat/heartbeat-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..0fe750c33700
--- /dev/null
+++ b/sys-cluster/heartbeat/heartbeat-3.0.5-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-3.0.5-r1.ebuild,v 1.1 2012/10/29 16:44:23 ultrabug Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python autotools multilib eutils base
+
+DESCRIPTION="Heartbeat high availability cluster manager"
+HOMEPAGE="http://www.linux-ha.org/wiki/Heartbeat"
+SRC_URI="http://hg.linux-ha.org/${PN}-STABLE_3_0/archive/STABLE-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc snmp static-libs"
+
+RDEPEND="sys-cluster/cluster-glue
+ dev-libs/glib:2
+ virtual/ssh
+ net-libs/gnutls
+ snmp? ( net-analyzer/net-snmp )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ doc? ( dev-libs/libxslt app-text/docbook-xsl-stylesheets )"
+
+PDEPEND="sys-cluster/resource-agents"
+
+S=${WORKDIR}/Heartbeat-3-0-STABLE-${PV}
+
+PATCHES=(
+ "${FILESDIR}/3.0.4-fix_configure.patch"
+ "${FILESDIR}/3.0.4-docs.patch"
+ "${FILESDIR}/3.0.4-python_tests.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ ewarn "If you're upgrading from heartbeat-2.x please follow:"
+ ewarn "http://www.gentoo.org/proj/en/cluster/ha-cluster/heartbeat-upgrade.xml"
+}
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+
+ cp "${FILESDIR}"/heartbeat-init "${T}" || die
+ sed -i \
+ -e "/ResourceManager/ s/lib/share/" \
+ -e "s:lib:$(get_libdir):g" \
+ "${T}"/heartbeat-init || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ $(use_enable static-libs static) \
+ $(use_enable doc) \
+ --disable-tipc \
+ --enable-dopd \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable snmp)
+}
+
+src_install() {
+ base_src_install
+
+ newinitd "${T}/heartbeat-init" heartbeat || die
+
+ # fix collisions
+ rm -rf "${D}"/usr/include/heartbeat/{compress,ha_msg}.h
+
+ use static-libs || find "${D}"/usr/$(get_libdir) -name "*.la" -delete
+
+ if use doc ; then
+ dodoc README doc/*.txt doc/AUTHORS || die
+ fi
+}