summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-14 19:35:58 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-14 19:35:58 +0000
commitb505fe2c55c026dfa8c91eeb4f0289ad640ce555 (patch)
tree65d00f071f97ca73228fb476fd90d03c2f588596 /sys-cluster
parentPrepare for fortran2.eclass update (diff)
downloadgentoo-2-b505fe2c55c026dfa8c91eeb4f0289ad640ce555.tar.gz
gentoo-2-b505fe2c55c026dfa8c91eeb4f0289ad640ce555.tar.bz2
gentoo-2-b505fe2c55c026dfa8c91eeb4f0289ad640ce555.zip
Prepare for fortran2.eclass update
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog7
-rw-r--r--sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild4
-rw-r--r--sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild4
-rw-r--r--sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild4
4 files changed, 14 insertions, 5 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 6eadcc5d0dea..a8839fdb7550 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.78 2012/06/25 18:33:23 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.79 2012/10/14 19:35:58 jlec Exp $
+
+ 14 Oct 2012; Justin Lecher <jlec@gentoo.org> mpich2-1.2.1_p1-r1.ebuild,
+ mpich2-1.4.1_p1.ebuild, mpich2-1.4_rc2-r1.ebuild:
+ Prepare for fortran2.eclass update
25 Jun 2012; Justin Bronder <jsbronder@gentoo.org> mpich2-1.2.1_p1-r1.ebuild,
mpich2-1.4_rc2-r1.ebuild, mpich2-1.4.1_p1.ebuild:
@@ -370,4 +374,3 @@
27 Dec 2005; Joel Martin <kanaka@gentoo.org> +metadata.xml,
+mpich2-1.0.2_p1.ebuild:
Create mpich2 ebuild for version 1.0.2-p1
-
diff --git a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
index d38f68e4cb63..5bd0a5976715 100644
--- a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.14 2012/06/25 18:33:23 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.15 2012/10/14 19:35:58 jlec Exp $
EAPI=2
+
PYTHON_DEPEND="2"
+FORTRAN_NEEDED=fortran
inherit eutils fortran-2 python toolchain-funcs
diff --git a/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild b/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild
index 8c4a1fadd26b..751c7b70aa6b 100644
--- a/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild,v 1.4 2012/06/25 18:33:23 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4.1_p1.ebuild,v 1.5 2012/10/14 19:35:58 jlec Exp $
EAPI=4
+FORTRAN_NEEDED=fortran
+
inherit autotools eutils fortran-2 toolchain-funcs
MY_PV=${PV/_/}
diff --git a/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
index 0b232d00721c..4b43a0db73c3 100644
--- a/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild,v 1.7 2012/06/25 18:33:23 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild,v 1.8 2012/10/14 19:35:58 jlec Exp $
EAPI=2
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 toolchain-funcs autotools
MY_PV=${PV/_/}