summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-09-04 06:11:18 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-09-04 06:11:18 +0000
commitb20583681d599d1e9c8c0402beca25ea801d6cb9 (patch)
tree3043c1d98fbd259cf73fe51466a584d5cc7cc7a9 /sys-cluster
parentVersion bump, adds Odyssey 1.1 updates and new import/export features. Drop old. (diff)
downloadgentoo-2-b20583681d599d1e9c8c0402beca25ea801d6cb9.tar.gz
gentoo-2-b20583681d599d1e9c8c0402beca25ea801d6cb9.tar.bz2
gentoo-2-b20583681d599d1e9c8c0402beca25ea801d6cb9.zip
sys-cluster/ploop: bump up to 1.9
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/ChangeLog7
-rw-r--r--sys-cluster/ploop/ploop-1.9.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index 5b217042398b..73cbc42c9374 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.19 2013/08/31 09:45:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.20 2013/09/04 06:11:18 qnikst Exp $
+
+*ploop-1.9 (04 Sep 2013)
+
+ 04 Sep 2013; Alexander Vershilov <qnikst@gentoo.org> +ploop-1.9.ebuild:
+ sys-cluster/ploop: bump up to 1.9
31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ploop-1.8.ebuild:
Stable for amd64, wrt bug #482394
diff --git a/sys-cluster/ploop/ploop-1.9.ebuild b/sys-cluster/ploop/ploop-1.9.ebuild
new file mode 100644
index 000000000000..4dbde87e3d5e
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.9.ebuild,v 1.1 2013/09/04 06:11:18 qnikst Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}
+ !<sys-cluster/vzctl-4.5
+ sys-block/parted
+ sys-fs/e2fsprogs
+ "
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+ use static-libs || rm "${D}/usr/$(get_libdir)/libploop.a" || die 'remove static lib failed'
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab79.5 and vzctl-4.5 ot above"
+ elog "2. DiskDescriptor.xml created by older ploop versions are converted to current format"
+ elog "3. If you have eise --diskquota paranetr on gentoo CT, please install sys-fs/quota on CT. "
+ elog "[3] is gentoo specific messages ( due stage3 not contain quta tools) "
+}