summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2011-02-01 18:27:09 +0000
committerJustin Bronder <jsbronder@gentoo.org>2011-02-01 18:27:09 +0000
commitac8916cd950c47f73534a50abc46e1253d0360ae (patch)
tree8ad8ff150e3608477c36052b29a5708b3144288f /sys-cluster
parentStable on amd64 wrt bug #353243 (diff)
downloadgentoo-2-ac8916cd950c47f73534a50abc46e1253d0360ae.tar.gz
gentoo-2-ac8916cd950c47f73534a50abc46e1253d0360ae.tar.bz2
gentoo-2-ac8916cd950c47f73534a50abc46e1253d0360ae.zip
Fix SRC_URI (thanks to renihs in #-cluster) and general cleanup.
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpl/ChangeLog10
-rw-r--r--sys-cluster/hpl/hpl-2.0-r1.ebuild (renamed from sys-cluster/hpl/hpl-2.0.ebuild)29
2 files changed, 24 insertions, 15 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index 75d3c16cb113..5a69cd594ae9 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/hpl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.16 2010/09/13 15:21:23 jsbronder Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.17 2011/02/01 18:27:08 jsbronder Exp $
+
+*hpl-2.0-r1 (01 Feb 2011)
+
+ 01 Feb 2011; Justin Bronder <jsbronder@gentoo.org> -hpl-2.0.ebuild,
+ +hpl-2.0-r1.ebuild:
+ Fix SRC_URI (thanks to renihs in #-cluster) and general cleanup.
13 Sep 2010; Justin Bronder <jsbronder@gentoo.org> hpl-2.0.ebuild:
Respect LDFLAGS #336969.
diff --git a/sys-cluster/hpl/hpl-2.0.ebuild b/sys-cluster/hpl/hpl-2.0-r1.ebuild
index 0a471d98eb53..74b4e88f8f2c 100644
--- a/sys-cluster/hpl/hpl-2.0.ebuild
+++ b/sys-cluster/hpl/hpl-2.0-r1.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0.ebuild,v 1.4 2010/09/13 15:21:23 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.1 2011/02/01 18:27:08 jsbronder Exp $
inherit eutils
DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
-SRC_URI="http://www.netlib.org/benchmark/hpl/hpl.tgz"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
LICENSE="HPL"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
-S="${WORKDIR}/${PN}"
+IUSE="doc"
DEPEND="virtual/mpi
virtual/blas
virtual/lapack"
@@ -23,6 +22,7 @@ src_unpack() {
cd "${S}"
cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
sed -i \
+ -e "/^TOPdir/s,= .*,= ${S}," \
-e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
-e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
-e '/^MPdir\>/s,= .*,=,' \
@@ -40,16 +40,19 @@ src_compile() {
}
src_install() {
- doman man/man3/*.3
- dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
- dobin bin/gentoo_hpl_fblas_x86/xhpl || die "Failed to install bins"
- insinto /usr/share/hpl
- doins bin/gentoo_hpl_fblas_x86/HPL.dat || die "Failed to install HPL parameters"
- dohtml -r www/*
- dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die "Failed to install lib"
+ dobin bin/gentoo_hpl_fblas_x86/xhpl || die
+ dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die
+ dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING \
+ bin/gentoo_hpl_fblas_x86/HPL.dat || die
+ doman man/man3/*.3 || die
+ if use doc; then
+ dohtml -r www/* || die
+ fi
}
pkg_postinst() {
einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory"
- einfo "before running xhpl."
+ einfo "before running xhpl. Typically one may run hpl by executing:"
+ einfo "\"mpiexec -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
}