summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-09-23 00:39:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-09-23 00:39:51 +0000
commit90c72edfd8fdcd8762963a0a2e4705d8269fa37c (patch)
treec158fd56a0d597b09f775297e688cbab18982a98 /sys-cluster
parentMarked stable on amd64 as per bug 189672. (diff)
downloadgentoo-2-90c72edfd8fdcd8762963a0a2e4705d8269fa37c.tar.gz
gentoo-2-90c72edfd8fdcd8762963a0a2e4705d8269fa37c.tar.bz2
gentoo-2-90c72edfd8fdcd8762963a0a2e4705d8269fa37c.zip
Cleanup of the main two ebuilds per dberkholz commit review.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/ChangeLog6
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild16
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.15.ebuild19
3 files changed, 23 insertions, 18 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index 43057e8aafcc..32b935cb260e 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.46 2007/09/22 19:12:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.47 2007/09/23 00:39:51 robbat2 Exp $
+
+ 23 Sep 2007; Robin H. Johnson <robbat2@gentoo.org>
+ keepalived-1.1.13-r1.ebuild, keepalived-1.1.15.ebuild:
+ Cleanup of the main two ebuilds per dberkholz commit review.
22 Sep 2007; nixnut <nixnut@gentoo.org> keepalived-1.1.13-r1.ebuild:
Stable on ppc wrt bug 181763
diff --git a/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild b/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild
index f89453937690..57cb5199bee3 100644
--- a/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild
+++ b/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild,v 1.5 2007/09/22 19:12:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.13-r1.ebuild,v 1.6 2007/09/23 00:39:51 robbat2 Exp $
inherit flag-o-matic autotools
@@ -25,17 +25,17 @@ src_unpack() {
# This patch allows us to avoid needing kernel sources for the configure phase
EPATCH_OPTS="-p1 -d${S}" epatch \
${FILESDIR}/${PN}-1.1.13-do-not-need-kernel-sources.patch
- cd ${S}
+ cd "${S}"
eautoreconf
# Prepare a suitable copy of the IPVS headers
# So that we don't need kernel sources at all!
- mkdir -p ${S}/include/net || die "Failed to prepare ipvs header directory"
- cp -f ${FILESDIR}/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
- ${S}/include/net/ip_vs.h || die "Failed to add ipvs header"
+ mkdir -p "${S}"/include/net || die "Failed to prepare ipvs header directory"
+ cp -f "${FILESDIR}"/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
+ "${S}"/include/net/ip_vs.h || die "Failed to add ipvs header"
# Ensure that keepalived can find the header that we are injecting
- append-flags -I${S}/include
+ append-flags -I"${S}"/include
}
src_compile() {
@@ -63,7 +63,7 @@ src_install() {
# Not parallel safe
emake -j1 install DESTDIR="${D}" || die "emake install failed"
- newinitd ${FILESDIR}/init-keepalived keepalived
+ newinitd "${FILESDIR}"/init-keepalived keepalived
dodoc doc/keepalived.conf.SYNOPSIS
dodoc README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
@@ -74,7 +74,7 @@ src_install() {
newdoc INSTALL INSTALL+HOWTO
# Security risk to bundle SSL certs
- rm -f ${D}/etc/keepalived/samples/*.pem
+ rm -f "${D}"/etc/keepalived/samples/*.pem
}
pkg_postinst() {
diff --git a/sys-cluster/keepalived/keepalived-1.1.15.ebuild b/sys-cluster/keepalived/keepalived-1.1.15.ebuild
index c7b752de4687..c624ed9ec33d 100644
--- a/sys-cluster/keepalived/keepalived-1.1.15.ebuild
+++ b/sys-cluster/keepalived/keepalived-1.1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.15.ebuild,v 1.1 2007/09/22 09:12:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.15.ebuild,v 1.2 2007/09/23 00:39:51 robbat2 Exp $
inherit flag-o-matic autotools
@@ -25,17 +25,17 @@ src_unpack() {
# This patch allows us to avoid needing kernel sources for the configure phase
EPATCH_OPTS="-p1 -d${S}" epatch \
${FILESDIR}/${PN}-1.1.13-do-not-need-kernel-sources.patch
- cd ${S}
+ cd "${S}"
eautoreconf
# Prepare a suitable copy of the IPVS headers
# So that we don't need kernel sources at all!
- mkdir -p ${S}/include/net || die "Failed to prepare ipvs header directory"
- cp -f ${FILESDIR}/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
- ${S}/include/net/ip_vs.h || die "Failed to add ipvs header"
+ mkdir -p "${S}"/include/net || die "Failed to prepare ipvs header directory"
+ cp -f "${FILESDIR}"/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
+ "${S}"/include/net/ip_vs.h || die "Failed to add ipvs header"
# Ensure that keepalived can find the header that we are injecting
- append-flags -I${S}/include
+ append-flags -I"${S}"/include
}
src_compile() {
@@ -63,7 +63,7 @@ src_install() {
# Not parallel safe
emake -j1 install DESTDIR="${D}" || die "emake install failed"
- newinitd ${FILESDIR}/init-keepalived keepalived
+ newinitd "${FILESDIR}"/init-keepalived keepalived
dodoc doc/keepalived.conf.SYNOPSIS
dodoc README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
@@ -74,8 +74,9 @@ src_install() {
newdoc INSTALL INSTALL+HOWTO
# Security risk to bundle SSL certs
- rm -f ${D}/etc/keepalived/samples/*.pem
- rm -rf ${D}/etc/sysconfig ${D}/etc/rc.d/
+ rm -f "${D}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${D}"/etc/sysconfig "${D}"/etc/rc.d/
}
pkg_postinst() {