summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-07-02 14:34:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-07-02 14:34:42 +0000
commit8ccd2ddfce2517aebee122b746db9f656c81f9b6 (patch)
tree06608abf74f73df27a1fc749f1ddf86acca29cbf /sys-cluster
parentWhitespace. (diff)
downloadgentoo-2-8ccd2ddfce2517aebee122b746db9f656c81f9b6.tar.gz
gentoo-2-8ccd2ddfce2517aebee122b746db9f656c81f9b6.tar.bz2
gentoo-2-8ccd2ddfce2517aebee122b746db9f656c81f9b6.zip
version bump for swift for havana
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/ChangeLog8
-rw-r--r--sys-cluster/swift/swift-1.9.0.ebuild130
2 files changed, 137 insertions, 1 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index 095823afd65c..2bd82907ec63 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/swift
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.9 2013/06/14 22:11:19 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.10 2013/07/02 14:34:42 prometheanfire Exp $
+
+*swift-1.9.0 (02 Jul 2013)
+
+ 02 Jul 2013; Matthew Thode <prometheanfire@gentoo.org> +swift-1.9.0.ebuild,
+ swift-1.7.6-r2.ebuild, swift-1.7.6-r3.ebuild, swift-1.8.0-r2.ebuild:
+ version bump for swift for havana
*swift-1.7.6-r3 (14 Jun 2013)
*swift-1.8.0-r2 (14 Jun 2013)
diff --git a/sys-cluster/swift/swift-1.9.0.ebuild b/sys-cluster/swift/swift-1.9.0.ebuild
new file mode 100644
index 000000000000..d8f79f0e5615
--- /dev/null
+++ b/sys-cluster/swift/swift-1.9.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.9.0.ebuild,v 1.1 2013/07/02 14:34:42 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+SRC_URI="http://launchpad.net/${PN}/havana/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="proxy account container object test +memcache"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.10.0-r1[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ memcache? ( net-misc/memcached )
+ net-misc/rsync[xattr]"
+# dev-python/configobj[${PYTHON_USEDEP}]
+# >=dev-python/webob-1.0.8[${PYTHON_USEDEP}]
+# <dev-python/webob-1.3[${PYTHON_USEDEP}]
+
+REQUIRED_USE="|| ( proxy account container object )"
+
+CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+~ZFS"
+
+PATCHES=(
+)
+# "${FILESDIR}/CVE-2013-2161.patch"
+
+src_test () {
+ sh .unittests || die
+}
+
+pkg_setup() {
+ enewuser swift
+ enewgroup swift
+}
+
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
+ sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/swift
+ insinto /etc/swift
+
+ newins "etc/swift.conf-sample" "swift.conf"
+ newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
+ newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+ newins "etc/mime.types-sample" "mime.types-sample"
+ newins "etc/memcache.conf-sample" "memcache.conf-sample"
+ newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+ newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+ if use proxy; then
+ newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+ newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+ if use memcache; then
+ sed -i '/depend/a\
+ need memcached' "${D}/etc/init.d/swift-proxy"
+ fi
+ fi
+ if use account; then
+ newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+ newins "etc/account-server.conf-sample" "account-server.conf"
+ fi
+ if use container; then
+ newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+ newins "etc/container-server.conf-sample" "container-server.conf"
+ fi
+ if use object; then
+ newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+ newins "etc/object-server.conf-sample" "object-server.conf"
+ newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+ fi
+
+ fowners swift:swift "/etc/swift" || die "fowners failed"
+}
+
+pkg_postinst() {
+ elog "Openstack swift will default to using insecure http unless a"
+ elog "certificate is created in /etc/swift/cert.crt and the associated key"
+ elog "in /etc/swift/cert.key. These can be created with the following:"
+ elog " * cd /etc/swift"
+ elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}
+
+#src_install()
+#{
+# distutils_src_install
+#
+# dodir "/var/run/swift"
+#
+# if use proxy-server; then
+# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
+# fi
+#
+# if use storage-server; then
+# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
+# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
+# fi
+#}