summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-17 13:07:51 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-17 13:07:51 +0000
commit7d7b66bd4f02482de8b2275e06a26ee30a64df06 (patch)
treea78f4ac94288a901739cd1e702694359049d69a4 /sys-cluster
parentOld. (diff)
downloadgentoo-2-7d7b66bd4f02482de8b2275e06a26ee30a64df06.tar.gz
gentoo-2-7d7b66bd4f02482de8b2275e06a26ee30a64df06.tar.bz2
gentoo-2-7d7b66bd4f02482de8b2275e06a26ee30a64df06.zip
[sys-cluster/ceph] Version bump
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog7
-rw-r--r--sys-cluster/ceph/ceph-0.55.1.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 12ea939a0957..464c92d14f22 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.26 2012/09/14 08:49:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.27 2012/12/17 13:07:51 alexxy Exp $
+
+*ceph-0.55.1 (17 Dec 2012)
+
+ 17 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.55.1.ebuild:
+ [sys-cluster/ceph] Version bump
*ceph-0.51 (14 Sep 2012)
diff --git a/sys-cluster/ceph/ceph-0.55.1.ebuild b/sys-cluster/ceph/ceph-0.55.1.ebuild
new file mode 100644
index 000000000000..69f37aa9c50a
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.55.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.55.1.ebuild,v 1.1 2012/12/17 13:07:51 alexxy Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+
+CDEPEND="
+ dev-libs/boost
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ sed -i -e '/AM_INIT_AUTOMAKE/s:-Werror ::' src/leveldb/configure.ac || die #423755
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ rmdir "${ED}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}