summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-06-25 15:48:20 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-06-25 15:48:20 +0000
commit661c8e36f9f57e1be8577b02833daf2d01e07cc7 (patch)
tree9c6dd9a4c0b163501534b20a3c1f5d10e148083c /sys-cluster
parentversion bump, drop buggy (diff)
downloadgentoo-2-661c8e36f9f57e1be8577b02833daf2d01e07cc7.tar.gz
gentoo-2-661c8e36f9f57e1be8577b02833daf2d01e07cc7.tar.bz2
gentoo-2-661c8e36f9f57e1be8577b02833daf2d01e07cc7.zip
Revision bump to pull in yet another important fix for 3.4.4 (client crash after rebalance, upstream bug #961615).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/ChangeLog10
-rw-r--r--sys-cluster/glusterfs/files/glusterfs-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch48
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild (renamed from sys-cluster/glusterfs/glusterfs-3.4.4-r1.ebuild)3
3 files changed, 59 insertions, 2 deletions
diff --git a/sys-cluster/glusterfs/ChangeLog b/sys-cluster/glusterfs/ChangeLog
index 302fb7b97fbf..d92ebf76aaa3 100644
--- a/sys-cluster/glusterfs/ChangeLog
+++ b/sys-cluster/glusterfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/glusterfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.56 2014/06/25 09:54:31 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.57 2014/06/25 15:48:20 dev-zero Exp $
+
+*glusterfs-3.4.4-r2 (25 Jun 2014)
+
+ 25 Jun 2014; Tiziano Müller <dev-zero@gentoo.org> +files/glusterfs-3.4.4-clust
+ er-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch,
+ +glusterfs-3.4.4-r2.ebuild, -glusterfs-3.4.4-r1.ebuild:
+ Revision bump to pull in yet another important fix for 3.4.4 (client crash
+ after rebalance, upstream bug #961615).
*glusterfs-3.4.4-r1 (25 Jun 2014)
diff --git a/sys-cluster/glusterfs/files/glusterfs-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch b/sys-cluster/glusterfs/files/glusterfs-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch
new file mode 100644
index 000000000000..c26085a9dfe7
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfs-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch
@@ -0,0 +1,48 @@
+From 2b789331dc933b186360fc8cbffb06289ee60ee9 Mon Sep 17 00:00:00 2001
+From: Vijay Bellur <vbellur@redhat.com>
+Date: Tue, 10 Jun 2014 22:21:28 +0530
+Subject: [PATCH 1/3] cluster/dht: Don't do extra unref in dht-migration checks
+
+Problem:
+syncop_open used to perform a ref in syncop_open_cbk so the extra
+unref was needed but now syncop_open_cbk does not take a ref so no
+need to do extra unref.
+
+Fix:
+remove the extra fd_unref and let dht_local_wipe do the final unref.
+
+Change-Id: Ibe8f9a678d456a0c7bff175306068b5cd297ecc4
+BUG: 961615
+Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
+Signed-off-by: Vijay Bellur <vbellur@redhat.com>
+Reviewed-on: http://review.gluster.org/8029
+Tested-by: Gluster Build System <jenkins@build.gluster.com>
+Tested-by: Joe Julian <joe@julianfamily.org>
+Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
+---
+ xlators/cluster/dht/src/dht-helper.c | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/xlators/cluster/dht/src/dht-helper.c b/xlators/cluster/dht/src/dht-helper.c
+index ef29e3f..dd8dc49 100644
+--- a/xlators/cluster/dht/src/dht-helper.c
++++ b/xlators/cluster/dht/src/dht-helper.c
+@@ -802,13 +802,10 @@ dht_migration_complete_check_task (void *data)
+ if (!local->fd)
+ goto out;
+ /* once we detect the migration complete, the fd-ctx is no more
+- required.. delete the ctx, and do one extra 'fd_unref' for open fd */
++ required.. delete the ctx */
+ ret = fd_ctx_del (local->fd, this, NULL);
+- if (!ret) {
+- fd_unref (local->fd);
+- ret = 0;
++ if (!ret)
+ goto out;
+- }
+
+ /* perform open as root:root. There is window between linkfile
+ * creation(root:root) and setattr with the correct uid/gid
+--
+1.9.2
+
diff --git a/sys-cluster/glusterfs/glusterfs-3.4.4-r1.ebuild b/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild
index edea95e962e1..4c25f5743797 100644
--- a/sys-cluster/glusterfs/glusterfs-3.4.4-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.4.4-r1.ebuild,v 1.1 2014/06/25 09:54:31 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild,v 1.1 2014/06/25 15:48:20 dev-zero Exp $
EAPI=5
@@ -42,6 +42,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
"${FILESDIR}/${PN}-3.4.0-build-shared-only.patch"
"${FILESDIR}/${PN}-3.4.4-fuse-fix-memory-leak-in-fuse_getxattr.patch"
+ "${FILESDIR}/${PN}-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch"
)
DOCS=( AUTHORS ChangeLog NEWS README THANKS )