summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-18 14:52:10 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-18 14:52:10 +0000
commit65586fd93713ae4dca2eedb03ebdc4d8261bc3c9 (patch)
treec29ca3e7d5d8318dce9d4f74085f81cd7bd6a252 /sys-cluster
parentAdding ~ia64 to the KEYWORDS. (diff)
downloadgentoo-2-65586fd93713ae4dca2eedb03ebdc4d8261bc3c9.tar.gz
gentoo-2-65586fd93713ae4dca2eedb03ebdc4d8261bc3c9.tar.bz2
gentoo-2-65586fd93713ae4dca2eedb03ebdc4d8261bc3c9.zip
Cleaning up the ebuild a bit (thanks to Kir Kolyshkin <kir@openvz.org> for being a pain in the ass :)).
(Portage version: 2.1.2)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog6
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild30
2 files changed, 20 insertions, 16 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 18bf532f562e..587bd04166b6 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.40 2007/01/18 09:40:03 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.41 2007/01/18 14:52:10 phreak Exp $
+
+ 18 Jan 2007; Christian Heim <phreak@gentoo.org> vzctl-3.0.14.ebuild:
+ Cleaning up the ebuild a bit (thanks to Kir Kolyshkin <kir@openvz.org> for
+ being a pain in the ass :)).
*vzctl-3.0.14 (18 Jan 2007)
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
index 3c769d65d8df..6211dd2973cf 100644
--- a/sys-cluster/vzctl/vzctl-3.0.14.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.14.ebuild,v 1.1 2007/01/18 09:40:03 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.14.ebuild,v 1.2 2007/01/18 14:52:10 phreak Exp $
-inherit bash-completion eutils flag-o-matic multilib
+inherit bash-completion eutils
-DESCRIPTION="OpenVZ VPS control utility"
+DESCRIPTION="OpenVZ VE control utility"
HOMEPAGE="http://openvz.org/"
SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
IUSE="bash-completion logrotate udev"
RDEPEND="logrotate? ( app-admin/logrotate )
@@ -29,25 +29,25 @@ src_unpack() {
}
src_compile() {
- econf --libdir=/usr/$(get_libdir) || die "econf failed!"
- emake CFLAGS="${CFLAGS}" || die "emake failed!"
+ econf --localstatedir=/var \
+ --enable-cron \
+ $(use_enable bash-completion bashcomp) \
+ $(use_enable logrotate) \
+ $(use_enable udev) || die "econf failed!"
+
+ emake || die "emake failed!"
}
src_install() {
make DESTDIR="${D}" install install-gentoo || die "make install failed"
- # Remove udev files unless USE=udev
- use udev || rm -rf "${D}"/etc/udev
-
- # Remove the bash-completion and use dobashcompletion to install it in the
- # right place!
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh.in vzctl
-
- # Remove the logrotate entry unless USE=logrotate
- use logrotate || rm -rf "${D}"/etc/logrotate.d
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
}
pkg_postinst() {
+ bash-completion_pkg_postinst
if has_version "<3.0.10"; then
ewarn
ewarn "The location of some vzctl files have changed. Most notably,"