summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:54:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:54:28 +0000
commit646006da478ab6289fa8e7167c807ce04a51914f (patch)
tree7e5117bd73a4d267e43d7c7a4ed11f88c86f84a2 /sys-cluster
parentVersion bump (diff)
downloadgentoo-2-646006da478ab6289fa8e7167c807ce04a51914f.tar.gz
gentoo-2-646006da478ab6289fa8e7167c807ce04a51914f.tar.bz2
gentoo-2-646006da478ab6289fa8e7167c807ce04a51914f.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog5
-rw-r--r--sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild11
2 files changed, 7 insertions, 9 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 2e1a03a7c007..a39675ed9b59 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.66 2010/11/29 16:14:20 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.67 2010/12/16 15:54:28 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> mpich2-1.2.1_p1-r1.ebuild:
+ Removal of fortran.eclass, #348851
29 Nov 2010; Justin Bronder <jsbronder@gentoo.org> -mpich2-1.0.8.ebuild,
metadata.xml:
diff --git a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
index 6d1ff27bcfa2..3c84924f3c41 100644
--- a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.9 2010/11/26 16:02:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.10 2010/12/16 15:54:28 jlec Exp $
EAPI=2
PYTHON_DEPEND="2"
-inherit eutils fortran python
+inherit eutils python toolchain-funcs
MY_PV=${PV/_/}
DESCRIPTION="MPICH2 - A portable MPI implementation"
@@ -35,11 +35,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- if use fortran ; then
- FORTRAN="g77 gfortran ifort ifc"
- fortran_pkg_setup
- fi
-
if use mpi-threads && ! use threads; then
ewarn "mpi-threads requires threads, assuming that's what you want"
fi
@@ -101,7 +96,7 @@ src_configure() {
fi
# enable f90 support for appropriate compilers
- case "${FORTRANC}" in
+ case "$(tc-getFC)" in
gfortran|if*)
c="${c} --enable-f77 --enable-f90";;
g77)