summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-07-06 09:17:20 +0000
committerChristian Heim <phreak@gentoo.org>2007-07-06 09:17:20 +0000
commit4368ba1ff1bfb4610812aa00dd4cb54d117af6f9 (patch)
tree795acaba21114d3fcdf66c8c119eeb7c70e1aa87 /sys-cluster
parentKeyworded ~x86-fbsd (diff)
downloadgentoo-2-4368ba1ff1bfb4610812aa00dd4cb54d117af6f9.tar.gz
gentoo-2-4368ba1ff1bfb4610812aa00dd4cb54d117af6f9.tar.bz2
gentoo-2-4368ba1ff1bfb4610812aa00dd4cb54d117af6f9.zip
Version bump, fixing 'a lot of bugs' either in code or documentation; ArchLinux support for VE's; init-script improvements as well as IPv6 fixes/improvements. For a full ChangeLog see http://git.openvz.org/?p=vzctl;a=shortlog;h=vzctl-3.0.17-1.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog10
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.173
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.17.ebuild55
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 78ff685ead5f..e269659a68eb 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.45 2007/06/03 07:35:50 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.46 2007/07/06 09:17:20 phreak Exp $
+
+*vzctl-3.0.17 (06 Jul 2007)
+
+ 06 Jul 2007; Christian Heim <phreak@gentoo.org> +vzctl-3.0.17.ebuild:
+ Version bump, fixing 'a lot of bugs' either in code or documentation;
+ ArchLinux support for VE's; init-script improvements as well as IPv6
+ fixes/improvements. For a full ChangeLog see
+ http://git.openvz.org/?p=vzctl;a=shortlog;h=vzctl-3.0.17-1.
03 Jun 2007; Christian Heim <phreak@gentoo.org> vzctl-3.0.16.ebuild:
Marking vzctl-3.0.16 stable on amd64 and x86.
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.17 b/sys-cluster/vzctl/files/digest-vzctl-3.0.17
new file mode 100644
index 000000000000..a68a676bd40f
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.17
@@ -0,0 +1,3 @@
+MD5 f7ad86b9219ccd09035b5f85a81b21e5 vzctl-3.0.17.tar.bz2 359457
+RMD160 cb10ce676975e9a0adfaab9cd69e84ceea761064 vzctl-3.0.17.tar.bz2 359457
+SHA256 4f915b8a9ef9fafd8656daf41aeac93998c64aab198cd89b47d53128501c2410 vzctl-3.0.17.tar.bz2 359457
diff --git a/sys-cluster/vzctl/vzctl-3.0.17.ebuild b/sys-cluster/vzctl/vzctl-3.0.17.ebuild
new file mode 100644
index 000000000000..03f20c4384ac
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.17.ebuild,v 1.1 2007/07/06 09:17:20 phreak Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="OpenVZ VE control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion logrotate"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --localstatedir=/var \
+ --enable-cron \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ $(use_enable logrotate) || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}