summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-05-02 03:10:28 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-05-02 03:10:28 +0000
commit41f1bee98eaba895ef103ee505e57af9755fae67 (patch)
tree16c6b71ad92f9a09a6d3a687cb749ffbea7967f7 /sys-cluster
parentFixing powerpc profiles for sys-libs/pam. (diff)
downloadgentoo-2-41f1bee98eaba895ef103ee505e57af9755fae67.tar.gz
gentoo-2-41f1bee98eaba895ef103ee505e57af9755fae67.tar.bz2
gentoo-2-41f1bee98eaba895ef103ee505e57af9755fae67.zip
gcc-4.3.0 compile fix (char *argv[] -> char **argv). Thanks to Peter Alfredsen (peter.alfredsen at gmail) for the report and fix. Bug #219675
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog6
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild18
2 files changed, 22 insertions, 2 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index ea8905204cba..1e589bb28fa5 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.66 2008/03/11 14:34:41 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.67 2008/05/02 03:10:28 jsbronder Exp $
+
+ 02 May 2008; Justin Bronder <jsbronder@gentoo.org> lam-mpi-7.1.4.ebuild:
+ gcc-4.3.0 compile fix (char *argv[] -> char **argv). Thanks to Peter
+ Alfredsen (peter.alfredsen at gmail) for the report and fix. Bug #219675
11 Mar 2008; Justin Bronder <jsbronder@gentoo.org>
+files/7.1.4-as-needed.patch, lam-mpi-7.0.4.ebuild, lam-mpi-7.1.2.ebuild,
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild
index 35deebf9dfb5..0c20b700a227 100644
--- a/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild,v 1.2 2008/03/11 14:34:41 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4.ebuild,v 1.3 2008/05/02 03:10:28 jsbronder Exp $
inherit autotools eutils fortran flag-o-matic multilib portability
@@ -39,6 +39,22 @@ src_unpack() {
epatch "${FILESDIR}"/7.1.2-lam_prog_f77.m4.patch
epatch "${FILESDIR}"/7.1.2-liblam-use-extra-libs.patch
epatch "${FILESDIR}"/7.1.4-as-needed.patch
+
+ # gcc-4.3.0 fix. char *argv[] -> char **argv.
+ # replaces a few more than necessary, but should be harmless.
+ # TODO: Already applied upstream, will be in 7.1.5
+ for f in config/*.m4; do
+ sed -i 's:^\(int main(int argc, char\)[^{]*\([{]\?\):\1** argv) \2:g' $f
+ done
+
+ # eautoreconf doesn't work correctly as lam-mpi uses their own
+ # LAM_CONFIG_SUBDIR instead of AC_CONFIG_SUBDIRS. Even better, they use
+ # variables inside of the definitions, so --trace doesn't work.
+ for f in $(find ./ -name 'configure.ac'); do
+ pushd $(dirname $f) &>/dev/null
+ eautoreconf
+ popd &>/dev/null
+ done
eautoreconf
}