summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-22 14:01:33 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-22 14:01:33 +0000
commit41a7629066fe534ae88b48e229f6f1e71ecb7c38 (patch)
treeb8ce161dd5591825edf15be05dfe915f5e9415fb /sys-cluster
parentBump to 1.12 (proxy commit) (diff)
downloadgentoo-2-41a7629066fe534ae88b48e229f6f1e71ecb7c38.tar.gz
gentoo-2-41a7629066fe534ae88b48e229f6f1e71ecb7c38.tar.bz2
gentoo-2-41a7629066fe534ae88b48e229f6f1e71ecb7c38.zip
Version bump, thanks to Andreis Vinogradovs
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/ChangeLog8
-rw-r--r--sys-cluster/ploop/files/ploop.tmpfiles1
-rw-r--r--sys-cluster/ploop/ploop-1.6.ebuild60
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index 8e46a73a552f..177e9055f9a9 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.8 2013/02/16 13:01:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.9 2013/02/22 14:01:33 pinkbyte Exp $
+
+*ploop-1.6 (22 Feb 2013)
+
+ 22 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +ploop-1.6.ebuild,
+ +files/ploop.tmpfiles:
+ Version bump, thanks to Andreis Vinogradovs
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #96436
diff --git a/sys-cluster/ploop/files/ploop.tmpfiles b/sys-cluster/ploop/files/ploop.tmpfiles
new file mode 100644
index 000000000000..25feee63db2a
--- /dev/null
+++ b/sys-cluster/ploop/files/ploop.tmpfiles
@@ -0,0 +1 @@
+d /run/lock/ploop 0755 root root - -
diff --git a/sys-cluster/ploop/ploop-1.6.ebuild b/sys-cluster/ploop/ploop-1.6.ebuild
new file mode 100644
index 000000000000..7ca424b22e31
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.6.ebuild,v 1.1 2013/02/22 14:01:33 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ epatch "${FILESDIR}/ploop-1.2-soname.patch"
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+ use static-libs || rm "${D}/usr/$(get_libdir)/libploop.a" || die 'remove static lib failed'
+
+ systemd_newtmpfilesd "${FILESDIR}/ploop.tmpfiles" ploop.conf
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab061.1"
+ elog "2. DiskDescriptor.xml created by older ploop versions are converted to current format"
+}