summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-01-12 09:45:49 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-01-12 09:45:49 +0000
commit409b7ab8c11bff5270854a92fd43fee17f0dc77e (patch)
tree1b6e6fb6c644a48a55fefff1aa4225aa3b6a6d34 /sys-cluster
parentAdd patch to fix building on ppc64 with GCC4, by replacing __u8 and __u32 wit... (diff)
downloadgentoo-2-409b7ab8c11bff5270854a92fd43fee17f0dc77e.tar.gz
gentoo-2-409b7ab8c11bff5270854a92fd43fee17f0dc77e.tar.bz2
gentoo-2-409b7ab8c11bff5270854a92fd43fee17f0dc77e.zip
Version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog9
-rw-r--r--sys-cluster/vzctl/Manifest14
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-2.7.0.251
-rw-r--r--sys-cluster/vzctl/vzctl-2.7.0.25.ebuild68
4 files changed, 79 insertions, 13 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 8509d78287db..9abc686f61f4 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/vzctl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.8 2005/12/26 07:32:22 hollow Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.9 2006/01/12 09:45:49 hollow Exp $
+
+*vzctl-2.7.0.25 (12 Jan 2006)
+
+ 12 Jan 2006; Benedikt Boehm <hollow@gentoo.org> +vzctl-2.7.0.25.ebuild:
+ Version bump
26 Dec 2005; Benedikt Boehm <hollow@gentoo.org> vzctl-2.7.0.24.ebuild:
marked stable amd64
diff --git a/sys-cluster/vzctl/Manifest b/sys-cluster/vzctl/Manifest
index 312828b3f92c..873ddfe707d9 100644
--- a/sys-cluster/vzctl/Manifest
+++ b/sys-cluster/vzctl/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 003f8daf1b54d10e59b5df3f01a237d1 ChangeLog 1516
+MD5 cc163caecc32257ca62905c9eab11219 ChangeLog 1637
MD5 8aea757fe2bda9943ef7cfd6d6c51fe6 files/digest-vzctl-2.7.0.24 66
+MD5 fdc2f878f8d875de1d34854ef14675c9 files/digest-vzctl-2.7.0.25 66
MD5 a2de79b189da1c2d3fd01fa2116bcea9 files/vz.initd 5465
MD5 687eaa4427600a7a5edfc0b8b7f69480 files/vzctl-2.7.0-gentoo_conf_d.patch 3899
MD5 48002ae17f4c768412ac70a33023d09d files/vzctl-2.7.0.23-gentoo_etc_vz.patch 7115
MD5 e5ba31c20aa49371e645a8950abd1054 metadata.xml 231
MD5 7b754de87e8fbf054cc37f7e5f1a3e15 vzctl-2.7.0.24.ebuild 1589
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDr5yUmPFBzbX68WERAjCZAJ0f3wzcjtzYeC+TBwJQj/EZac04EwCdGbJC
-9Qepvfh2IJ5c04hkQwhInpw=
-=L36U
------END PGP SIGNATURE-----
+MD5 331e85a09e0ca17349d18d3e3f42160c vzctl-2.7.0.25.ebuild 1591
diff --git a/sys-cluster/vzctl/files/digest-vzctl-2.7.0.25 b/sys-cluster/vzctl/files/digest-vzctl-2.7.0.25
new file mode 100644
index 000000000000..e4562890a9ae
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-2.7.0.25
@@ -0,0 +1 @@
+MD5 4b588927a590c8e91b185ba9442f97d6 vzctl-2.7.0-25.tar.bz2 98704
diff --git a/sys-cluster/vzctl/vzctl-2.7.0.25.ebuild b/sys-cluster/vzctl/vzctl-2.7.0.25.ebuild
new file mode 100644
index 000000000000..59507f08d778
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-2.7.0.25.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-2.7.0.25.ebuild,v 1.1 2006/01/12 09:45:49 hollow Exp $
+
+inherit eutils toolchain-funcs versionator linux-info
+
+VVER="$(get_version_component_range 1-3 ${PV})"
+VREL="$(get_version_component_range 4 ${PV})"
+MY_PV="${VVER}-${VREL}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${MY_PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/logrotate
+ app-shells/bash
+ sys-apps/sed
+ sys-apps/ed
+ sys-apps/grep
+ sys-apps/gawk
+ sys-apps/coreutils
+ net-firewall/iptables
+ app-arch/tar
+ sys-fs/vzquota
+ sys-process/procps
+ sys-apps/iproute2"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="FAIRSCHED VE VE_CALLS VE_NETDEV VE_IPTABLES"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ check_kernel_built
+}
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}" || die
+
+ epatch "${FILESDIR}"/vzctl-2.7.0-gentoo_conf_d.patch
+ epatch "${FILESDIR}"/vzctl-2.7.0.23-gentoo_etc_vz.patch
+}
+
+src_compile() {
+ emake VZKERNEL_HEADERS=${KV_DIR}/include || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" VZCONFDIR=/etc/conf.d/ install || die "make install failed"
+
+ # sysconfig is vendor specific
+ rm -rf ${D}/etc/sysconfig/network-scripts
+
+ # Install gentoo specific init script
+ rm -f ${D}/etc/init.d/*
+ newinitd ${FILESDIR}/vz.initd vz
+
+ # Fix permissions on cron.d files
+ chmod 0644 ${D}/etc/cron.d/*
+}