summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-06-22 04:28:44 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-06-22 04:28:44 +0000
commit320a5b2f6a4bfa7a0f3c679f3a96242daf624520 (patch)
tree51289256b0418cf5b12896ac3070566c87257b7f /sys-cluster
parentpmask media-tv/zapping for bug # 27515 (diff)
downloadgentoo-2-320a5b2f6a4bfa7a0f3c679f3a96242daf624520.tar.gz
gentoo-2-320a5b2f6a4bfa7a0f3c679f3a96242daf624520.tar.bz2
gentoo-2-320a5b2f6a4bfa7a0f3c679f3a96242daf624520.zip
fix libdir; add warning
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog5
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.10.ebuild26
2 files changed, 21 insertions, 10 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index da9a890e772c..f3c84385e283 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.25 2006/06/19 20:29:50 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.26 2006/06/22 04:28:44 hollow Exp $
+
+ 22 Jun 2006; Benedikt Böhm <hollow@gentoo.org> vzctl-3.0.10.ebuild:
+ fix libdir; add warning
*vzctl-3.0.10 (19 Jun 2006)
diff --git a/sys-cluster/vzctl/vzctl-3.0.10.ebuild b/sys-cluster/vzctl/vzctl-3.0.10.ebuild
index 9a8df00f467d..c1bf540dccbb 100644
--- a/sys-cluster/vzctl/vzctl-3.0.10.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.10.ebuild,v 1.1 2006/06/19 20:29:50 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.10.ebuild,v 1.2 2006/06/22 04:28:44 hollow Exp $
inherit eutils
@@ -14,29 +14,37 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="app-admin/logrotate
- app-shells/bash
- sys-apps/sed
sys-apps/ed
- sys-apps/grep
- sys-apps/gawk
- sys-apps/coreutils
net-firewall/iptables
- app-arch/tar
sys-fs/vzquota
- sys-process/procps
sys-apps/iproute2"
DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
+ cd "${S}"
+
epatch "${FILESDIR}"/${P}-Makefile.patch
epatch "${FILESDIR}"/${P}-as-needed.patch
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install || die "make install failed"
# Install gentoo specific init script
newinitd "${FILESDIR}"/vz.initd vz
}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}