summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-18 04:31:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-18 04:31:29 +0000
commit1ea60fa7e3fb4a32d01b1bb0dc2767bee3e557e1 (patch)
treee82de661af70d02c1183b568ee23e912e07586de /sys-cluster
parent[sys-cluster/slurm] Fix build (diff)
downloadgentoo-2-1ea60fa7e3fb4a32d01b1bb0dc2767bee3e557e1.tar.gz
gentoo-2-1ea60fa7e3fb4a32d01b1bb0dc2767bee3e557e1.tar.bz2
gentoo-2-1ea60fa7e3fb4a32d01b1bb0dc2767bee3e557e1.zip
[sys-cluster/slurm] Fix hard dep for gtk+ O_o
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/slurm/ChangeLog6
-rw-r--r--sys-cluster/slurm/files/slurm-2.5.0-nogtk.patch42
-rw-r--r--sys-cluster/slurm/slurm-2.5.0.ebuild17
3 files changed, 60 insertions, 5 deletions
diff --git a/sys-cluster/slurm/ChangeLog b/sys-cluster/slurm/ChangeLog
index 11254c18c14f..e7b38275263c 100644
--- a/sys-cluster/slurm/ChangeLog
+++ b/sys-cluster/slurm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/slurm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/ChangeLog,v 1.18 2012/12/18 04:09:51 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/ChangeLog,v 1.19 2012/12/18 04:31:29 alexxy Exp $
+
+ 18 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/slurm-2.5.0-nogtk.patch, slurm-2.5.0.ebuild:
+ [sys-cluster/slurm] Fix hard dep for gtk+ O_o
18 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> slurm-2.4.5.ebuild,
slurm-2.5.0.ebuild:
diff --git a/sys-cluster/slurm/files/slurm-2.5.0-nogtk.patch b/sys-cluster/slurm/files/slurm-2.5.0-nogtk.patch
new file mode 100644
index 000000000000..3a8003c28626
--- /dev/null
+++ b/sys-cluster/slurm/files/slurm-2.5.0-nogtk.patch
@@ -0,0 +1,42 @@
+--- slurm-2.5.0/configure.ac.orig 2012-12-18 08:20:19.403190646 +0400
++++ slurm-2.5.0/configure.ac 2012-12-18 08:20:48.293190615 +0400
+@@ -229,39 +229,6 @@
+ AM_CONDITIONAL(HAVE_SOME_CURSES, test "x$ac_have_some_curses" = "xyes")
+ AC_SUBST(HAVE_SOME_CURSES)
+
+-#
+-# Tests for GTK+
+-#
+-
+-# use the correct libs if running on 64bit
+-if test -d "/usr/lib64/pkgconfig"; then
+- PKG_CONFIG_PATH="/usr/lib64/pkgconfig/:$PKG_CONFIG_PATH"
+-fi
+-
+-if test -d "/opt/gnome/lib64/pkgconfig"; then
+- PKG_CONFIG_PATH="/opt/gnome/lib64/pkgconfig/:$PKG_CONFIG_PATH"
+-fi
+-
+-AM_PATH_GLIB_2_0([2.7.1], [ac_glib_test="yes"], [ac_glib_test="no"], [gthread])
+-AM_CONDITIONAL(BUILD_SVIEW, test "x$ac_glib_test" = "xyes")
+-
+-if test ${glib_config_minor_version=0} -ge 32 ; then
+- AC_DEFINE([GLIB_NEW_THREADS], 1, [Define to 1 if using glib-2.32.0 or higher])
+-fi
+-
+-AM_PATH_GTK_2_0([2.7.1], [ac_gtk_test="yes"], [ac_gtk_test="no"], [gthread])
+-if test ${gtk_config_minor_version=0} -ge 10 ; then
+- AC_DEFINE([GTK2_USE_RADIO_SET], 1, [Define to 1 if using gtk+-2.10.0 or higher])
+-fi
+-
+-if test ${gtk_config_minor_version=0} -ge 12 ; then
+- AC_DEFINE([GTK2_USE_TOOLTIP], 1, [Define to 1 if using gtk+-2.12.0 or higher])
+-fi
+-
+-if test ${gtk_config_minor_version=0} -ge 14 ; then
+- AC_DEFINE([GTK2_USE_GET_FOCUS], 1, [Define to 1 if using gtk+-2.14.0 or higher])
+-fi
+-
+ X_AC_DATABASES
+
+ dnl Cray ALPS/Basil support depends on mySQL
diff --git a/sys-cluster/slurm/slurm-2.5.0.ebuild b/sys-cluster/slurm/slurm-2.5.0.ebuild
index f88ada38e9e2..eeba69a390af 100644
--- a/sys-cluster/slurm/slurm-2.5.0.ebuild
+++ b/sys-cluster/slurm/slurm-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/slurm-2.5.0.ebuild,v 1.2 2012/12/18 04:09:51 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/slurm-2.5.0.ebuild,v 1.3 2012/12/18 04:31:29 alexxy Exp $
EAPI=4
@@ -23,7 +23,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-inherit base eutils pam perl-module user ${INHERIT_GIT}
+inherit autotools base eutils pam perl-module user ${INHERIT_GIT}
DESCRIPTION="SLURM: A Highly Scalable Resource Manager"
HOMEPAGE="http://www.schedmd.com"
@@ -56,8 +56,8 @@ LIBSLURMDB_PERL_S="${WORKDIR}/${P}/contribs/perlapi/libslurmdb/perl"
RESTRICT="primaryuri"
-PATHCES=(
- "${FILESDIR}/${PN}-2.3.4-glibc2.16.patch"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.0-nogtk.patch"
)
src_unpack() {
@@ -97,6 +97,15 @@ src_prepare() {
sed -e 's:/tmp:/var/tmp:g' \
-i "${S}/etc/slurm.conf.example" \
|| die "Can't sed for StateSaveLocation=*./tmp"
+ # disable sview since it need gtk+
+ sed -e '/sview/d' \
+ -i configure.ac
+ sed -e 's:sview::g' \
+ -i src/Makefile.am
+ # apply patches
+ epatch "${PATCHES[@]}"
+ elibtoolize
+ eautoreconf
}
src_configure() {