summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-09 14:32:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-09 14:32:13 +0000
commit1bd2b16149e6b1a15272b6a01bd92a198b980b5b (patch)
tree1be27a5373379ed22ef6aa39efded5b392374e61 /sys-cluster
parentUpdate tarball to not use screwed one released by upstream. Revbump to force ... (diff)
downloadgentoo-2-1bd2b16149e6b1a15272b6a01bd92a198b980b5b.tar.gz
gentoo-2-1bd2b16149e6b1a15272b6a01bd92a198b980b5b.tar.bz2
gentoo-2-1bd2b16149e6b1a15272b6a01bd92a198b980b5b.zip
Use Python 2.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
index 76557bbaf9fb..65cfab7bf380 100644
--- a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
+++ b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
@@ -1,24 +1,34 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.1 2010/06/09 02:19:25 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.2 2010/06/09 14:32:13 arfrever Exp $
EAPI=3
PYTHON_DEPEND="2"
PYTHON_MODNAME="pbs"
+
inherit distutils
MY_P=${P/-/_}
+
DESCRIPTION="Python bindings to the Torque C API"
HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
+
LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64"
IUSE="examples"
+
RDEPEND="sys-cluster/torque"
DEPEND="${RDEPEND}"
+
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
if use examples; then