summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-06-13 18:57:53 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-06-13 18:57:53 +0000
commit1434b025e1f61ff11c2f84a06577559d8d76f985 (patch)
tree2ca30c45239deae8865e3db7e933432ef22c8ce5 /sys-cluster
parentFix building with glibc-2.10, bug #273503 (diff)
downloadgentoo-2-1434b025e1f61ff11c2f84a06577559d8d76f985.tar.gz
gentoo-2-1434b025e1f61ff11c2f84a06577559d8d76f985.tar.bz2
gentoo-2-1434b025e1f61ff11c2f84a06577559d8d76f985.zip
Patch mpd to detect python2.6, #269856
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog6
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch29
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.8.ebuild12
3 files changed, 44 insertions, 3 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index aed5683f38b5..ad2d4a6a28b2 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.37 2009/05/02 12:46:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.38 2009/06/13 18:57:52 jsbronder Exp $
+
+ 13 Jun 2009; Justin Bronder <jsbronder@gentoo.org> mpich2-1.0.8.ebuild,
+ +files/mpich2-1.0.8-py26.patch:
+ Patch mpd to detect python2.6, #269856
02 May 2009; Raúl Porcel <armin76@gentoo.org> mpich2-1.0.8.ebuild:
x86 stable wrt #266409
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch b/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch
new file mode 100644
index 000000000000..52e22b8e81be
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.0.8-py26.patch
@@ -0,0 +1,29 @@
+diff -urN a/mpich2-1.0.8/src/pm/mpd/configure.in b/mpich2-1.0.8/src/pm/mpd/configure.in
+--- a/mpich2-1.0.8/src/pm/mpd/configure.in 2008-03-08 16:58:08.000000000 -0500
++++ b/mpich2-1.0.8/src/pm/mpd/configure.in 2009-06-13 14:01:38.921760910 -0400
+@@ -81,13 +81,15 @@
+ # echo "GOT PYTHON", $PYTHON
+ if test -z "$PYTHON" ; then ## user did not give us a python; find one
+ dnl Find a Python
++ AC_CHECK_PROG(PY26, python2.6, python2.6)
+ AC_CHECK_PROG(PY25, python2.5, python2.5)
+ AC_CHECK_PROG(PY24, python2.4, python2.4)
+ AC_CHECK_PROG(PY23, python2.3, python2.3)
+ AC_CHECK_PROG(PY22, python2.2, python2.2)
+ AC_CHECK_PROG(PY2, python2, python2)
+ AC_CHECK_PROG(PY, python, python)
+- if test -z "$PY25" -a \
++ if test -z "$PY26" -a \
++ -z "$PY25" -a \
+ -z "$PY24" -a \
+ -z "$PY23" -a \
+ -z "$PY22" -a \
+@@ -96,7 +98,7 @@
+ AC_MSG_WARN([Could not find a python executable in path: $PATH])
+ fi
+ dnl See if one of the pythons has the right modules
+- for pypgm in $PY25 $PY24 $PY23 $PY22 $PY2 $PY ; do \
++ for pypgm in $PY26 $PY25 $PY24 $PY23 $PY22 $PY2 $PY ; do \
+ AC_MSG_CHECKING([that $pypgm is a valid python version])
+ changequote(,)dnl
+ py_version=`$pypgm -c "import sys;print sys.version_info[0]"`
diff --git a/sys-cluster/mpich2/mpich2-1.0.8.ebuild b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
index 6723b77ce340..12d6f44c372c 100644
--- a/sys-cluster/mpich2/mpich2-1.0.8.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.7 2009/05/02 12:46:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.8 2009/06/13 18:57:52 jsbronder Exp $
EAPI=1
-inherit python eutils fortran
+inherit python eutils fortran autotools
DESCRIPTION="MPICH2 - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
@@ -98,6 +98,14 @@ src_unpack() {
# These tests in errhan/ rely on MPI::File ...which is in romio
echo "" > test/mpi/errors/cxx/errhan/testlist
fi
+
+ # #269856, detect python 2.6
+ # TODO: Send upstream
+ epatch "${FILESDIR}"/${P}-py26.patch
+ pushd "${S}"/src/pm/mpd >/dev/null || die "Missing src/pm/mpd"
+ cat aclocal_mpd.m4 "${S}"/confdb/aclocal_subcfg.m4 > aclocal.m4
+ AT_M4DIR=${S}/confdb eautoreconf
+ popd >/dev/null
}
src_compile() {