summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2011-01-10 09:22:14 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2011-01-10 09:22:14 +0000
commit099132b3c6182781f46f4a7267f5db7ac5a14032 (patch)
tree0ce471489aea00812b046634bb362d9ca5dc2379 /sys-cluster
parentStable on amd64 wrt bug #350772 (diff)
downloadgentoo-2-099132b3c6182781f46f4a7267f5db7ac5a14032.tar.gz
gentoo-2-099132b3c6182781f46f4a7267f5db7ac5a14032.tar.bz2
gentoo-2-099132b3c6182781f46f4a7267f5db7ac5a14032.zip
Add libnet USE flag. Fixes bug #348783. Thanks to Denis Kaganovich for reporting.
(Portage version: 2.1.9.29/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/resource-agents/ChangeLog11
-rw-r--r--sys-cluster/resource-agents/metadata.xml3
-rw-r--r--sys-cluster/resource-agents/resource-agents-1.0.3-r1.ebuild (renamed from sys-cluster/resource-agents/resource-agents-1.0.3.ebuild)11
3 files changed, 18 insertions, 7 deletions
diff --git a/sys-cluster/resource-agents/ChangeLog b/sys-cluster/resource-agents/ChangeLog
index dc114b6aaf50..8e491e5e77ad 100644
--- a/sys-cluster/resource-agents/ChangeLog
+++ b/sys-cluster/resource-agents/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/resource-agents
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/ChangeLog,v 1.4 2010/08/28 09:16:01 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/ChangeLog,v 1.5 2011/01/10 09:22:14 ultrabug Exp $
+
+*resource-agents-1.0.3-r1 (10 Jan 2011)
+
+ 10 Jan 2011; Ultrabug <ultrabug@gentoo.org> -resource-agents-1.0.3.ebuild,
+ +resource-agents-1.0.3-r1.ebuild, metadata.xml:
+ Add libnet USE flag. Fixes bug #348783. Thanks to Denis Kaganovich for
+ reporting.
28 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
resource-agents-1.0.3.ebuild:
diff --git a/sys-cluster/resource-agents/metadata.xml b/sys-cluster/resource-agents/metadata.xml
index 9716860e4017..fc14aaf4f652 100644
--- a/sys-cluster/resource-agents/metadata.xml
+++ b/sys-cluster/resource-agents/metadata.xml
@@ -9,4 +9,7 @@
failure. Previously, they were a part of the then-monolithic Heartbeat
project, and had no collective name.
</longdescription>
+ <use>
+ <flag name="libnet">Force use of <pkg>net-libs/libnet</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sys-cluster/resource-agents/resource-agents-1.0.3.ebuild b/sys-cluster/resource-agents/resource-agents-1.0.3-r1.ebuild
index c8b33f6dd358..1bd1111aec1f 100644
--- a/sys-cluster/resource-agents/resource-agents-1.0.3.ebuild
+++ b/sys-cluster/resource-agents/resource-agents-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/resource-agents-1.0.3.ebuild,v 1.4 2010/08/28 09:16:01 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/resource-agents-1.0.3-r1.ebuild,v 1.1 2011/01/10 09:22:14 ultrabug Exp $
EAPI="2"
@@ -14,11 +14,12 @@ SRC_URI="http://hg.linux-ha.org/agents/archive/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="doc"
+IUSE="doc libnet"
DEPEND="sys-apps/iproute2
sys-cluster/cluster-glue
- !<sys-cluster/heartbeat-3.0"
+ !<sys-cluster/heartbeat-3.0
+ libnet? ( <net-libs/libnet-1.1.5 )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/Cluster-Resource-Agents-${MY_P}"
@@ -42,7 +43,7 @@ src_configure() {
--libdir=/usr/$(get_libdir) \
--with-ocf-root=/usr/$(get_libdir)/ocf \
$(use_enable doc) \
- --enable-libnet
+ $(use_enable libnet)
}
src_install() {