summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-09-10 10:04:45 +0000
committerMichael Imhof <tantive@gentoo.org>2003-09-10 10:04:45 +0000
commitc01251ae9934eb8eb9e99c4eca3ce4747cd8980f (patch)
tree44d9a08bf19c77884fdfb856aa4311cce22283c2 /sys-cluster/xpvm
parentVersion bumped. Submitted by the <the@weird-birds.org>. Should close #28329. (diff)
downloadgentoo-2-c01251ae9934eb8eb9e99c4eca3ce4747cd8980f.tar.gz
gentoo-2-c01251ae9934eb8eb9e99c4eca3ce4747cd8980f.tar.bz2
gentoo-2-c01251ae9934eb8eb9e99c4eca3ce4747cd8980f.zip
Version bumped. Submitted by the <the@weird-birds.org>. Should close #28329.
Diffstat (limited to 'sys-cluster/xpvm')
-rw-r--r--sys-cluster/xpvm/ChangeLog9
-rw-r--r--sys-cluster/xpvm/Manifest2
-rw-r--r--sys-cluster/xpvm/files/digest-xpvm-1.2.5-r21
-rw-r--r--sys-cluster/xpvm/xpvm-1.2.5-r2.ebuild64
4 files changed, 73 insertions, 3 deletions
diff --git a/sys-cluster/xpvm/ChangeLog b/sys-cluster/xpvm/ChangeLog
index 069e65cd797e..bd80418e2a86 100644
--- a/sys-cluster/xpvm/ChangeLog
+++ b/sys-cluster/xpvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/xpvm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/ChangeLog,v 1.3 2003/07/10 11:17:41 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/ChangeLog,v 1.4 2003/09/10 10:04:35 tantive Exp $
+
+*xpvm-1.2.5-r2 (10 Sep 2003)
+
+ 10 Sep 2003; Michael Imhof <tantive@gentoo.org> xpvm-1.2.5-r2.ebuild:
+ Version bumped. Submitted by the <the@weird-birds.org>.
+ Should close #28329.
*xpvm-1.2.5-r1 (10 Jul 2003)
@@ -8,7 +14,6 @@
Submitted by the <the@weird-birds.org>.
Should close #24198.
-
*xpvm-1.2.5 (22 Jun 2003)
22 Jun 2003; Michael Imhof <tantive@gentoo.org>:
diff --git a/sys-cluster/xpvm/Manifest b/sys-cluster/xpvm/Manifest
index 771f7ec9cb5e..d1f27632158b 100644
--- a/sys-cluster/xpvm/Manifest
+++ b/sys-cluster/xpvm/Manifest
@@ -1,5 +1,5 @@
MD5 f98f1e822673bb15499b1a1f0f4046cb xpvm-1.2.5.ebuild 1516
-MD5 747127579edb7df7dfed8a75818b8462 ChangeLog 527
+MD5 fe3ae41c07fc8a03254d2b8163df171f ChangeLog 711
MD5 c27701d17dc82621b8d26122015fc9f0 xpvm-1.2.5-r1.ebuild 1437
MD5 beb9efce81ae2c582a621528fc783095 metadata.xml 373
MD5 878e2083e8c2ddc808c3d2eb3a5ebfa3 xpvm-1.2.5-r2.ebuild 1435
diff --git a/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r2 b/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r2
new file mode 100644
index 000000000000..b9694694f22c
--- /dev/null
+++ b/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r2
@@ -0,0 +1 @@
+MD5 7b20143cb2ff61e3cb28baf8f9cb2770 XPVM.src.1.2.5.tgz 196004
diff --git a/sys-cluster/xpvm/xpvm-1.2.5-r2.ebuild b/sys-cluster/xpvm/xpvm-1.2.5-r2.ebuild
new file mode 100644
index 000000000000..1ee304b7dcf1
--- /dev/null
+++ b/sys-cluster/xpvm/xpvm-1.2.5-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XPVM: A graphical console and monitor for PVM"
+SRC_URI="http://www.netlib.org/pvm3/xpvm/XPVM.src.1.2.5.tgz"
+HOMEPAGE="http://www.csm.ornl.gov/pvm/pvm_home.html"
+IUSE=""
+
+DEPEND=">=sys-cluster/pvm-3.4.1-r1
+ =dev-lang/tcl-8.3*
+ =dev-lang/tk-8.3*"
+RDEPEND=""
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="LGPL-2"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${FILESDIR}/xpvm-1.2.5-gentoo.diff || die
+}
+
+src_compile() {
+ cd ${WORKDIR}/xpvm
+
+ export PVM_ROOT="/usr/local/pvm3"
+ export PVM_ARCH="LINUX"
+ export XPVM_ROOT=${WORKDIR}"/xpvm"
+
+ emake xpvm || die
+}
+
+src_install() {
+ cd ${WORKDIR}/xpvm
+ dodir ${PVM_ROOT}"/xpvm"
+ dodir ${PVM_ROOT}"/bin/"${PVM_ARCH}
+ dodir "/usr/bin"
+
+ export XPVM_ROOT=${PVM_ROOT}"/xpvm"
+
+ #create symlinks to xpvm binary
+ dosym ${XPVM_ROOT}"/src/"${PVM_ARCH}"/xpvm" ${PVM_ROOT}"/bin/"${PVM_ARCH}"/xpvm"
+ dosym ${XPVM_ROOT}"/src/"${PVM_ARCH}"/xpvm" "/usr/bin/xpvm"
+
+ #install headers and libs and binary
+ export PVM_ROOT=${D}"/usr/local/pvm3"
+ cp ${WORKDIR}/xpvm ${PVM_ROOT} -r
+
+ #environment variables:
+ touch 97xpvm
+ echo XPVM_ROOT=/usr/local/pvm3/xpvm/src >>97xpvm
+ insinto /etc/env.d
+ doins 97xpvm
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Environment Variables have changed. Do not forget to reboot or perform"
+ ewarn "source /etc/profile before using xpvm !"
+}
+