summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-07-09 10:29:24 +0000
committerChristian Heim <phreak@gentoo.org>2006-07-09 10:29:24 +0000
commitcbb08949f0d3e53b99b6008dcf7ea98ca8774940 (patch)
treef930fb159ac4fc91afefdede53252023f7e5b5f3 /sys-cluster/vzctl
parentRevision bump, fixing some rpm related issues (diff)
downloadgentoo-2-cbb08949f0d3e53b99b6008dcf7ea98ca8774940.tar.gz
gentoo-2-cbb08949f0d3e53b99b6008dcf7ea98ca8774940.tar.bz2
gentoo-2-cbb08949f0d3e53b99b6008dcf7ea98ca8774940.zip
Revision bump, hopefully completly fixing #138462 and #138469
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.10-r23
-rw-r--r--sys-cluster/vzctl/files/vz-3.0.10.initd7
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.10-r2.ebuild52
4 files changed, 68 insertions, 2 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index c8e96aba3d3e..f1aa7486f2b8 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.27 2006/06/28 14:39:09 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.28 2006/07/09 10:29:24 phreak Exp $
+
+*vzctl-3.0.10-r2 (09 Jul 2006)
+
+ 09 Jul 2006; Christian Heim <phreak@gentoo.org> files/vz-3.0.10.initd,
+ +vzctl-3.0.10-r2.ebuild:
+ Revision bump, hopefully completly fixing #138462 and #138469
*vzctl-3.0.10-r1 (28 Jun 2006)
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.10-r2 b/sys-cluster/vzctl/files/digest-vzctl-3.0.10-r2
new file mode 100644
index 000000000000..d1e71e8f4e47
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.10-r2
@@ -0,0 +1,3 @@
+MD5 790dc15a779764a453b11c2368bccc40 vzctl-3.0.10.tar.bz2 124070
+RMD160 e3a1ae0846a5b7b8a054fb416c20eb7ae57d0008 vzctl-3.0.10.tar.bz2 124070
+SHA256 5509857493533cf68b55a2183154aac12d23ab65d555db3b4328c0619ca8080f vzctl-3.0.10.tar.bz2 124070
diff --git a/sys-cluster/vzctl/files/vz-3.0.10.initd b/sys-cluster/vzctl/files/vz-3.0.10.initd
index 7ba0eaa5cffc..6a7149e8f871 100644
--- a/sys-cluster/vzctl/files/vz-3.0.10.initd
+++ b/sys-cluster/vzctl/files/vz-3.0.10.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/files/vz-3.0.10.initd,v 1.1 2006/06/28 14:39:09 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/files/vz-3.0.10.initd,v 1.2 2006/07/09 10:29:24 phreak Exp $
depend() {
need net
@@ -19,6 +19,7 @@ check_config() {
: ${VPSCONFDIR:=/etc/vz}
: ${PRELOAD_MODULES:="af_packet"}
: ${MODULES:="vzmon vzdquota vzdev"}
+ : ${MIGRATE_MODULES:="vzcpt vzrst"}
: ${NET_MODULES="vznetdev vznet"}
: ${VZDEV:=venet0}
: ${PARALLEL:=4}
@@ -227,6 +228,10 @@ start() {
return ${rc}
fi
done
+
+ for mod in ${MIGRATE_MODULES}; do
+ /sbin/modprobe ${mod} >/dev/null 2>&1
+ done
eend
start_net
diff --git a/sys-cluster/vzctl/vzctl-3.0.10-r2.ebuild b/sys-cluster/vzctl/vzctl-3.0.10-r2.ebuild
new file mode 100644
index 000000000000..9bb1af62d6dd
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.10-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.10-r2.ebuild,v 1.1 2006/07/09 10:29:24 phreak Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/logrotate
+ sys-apps/ed
+ net-firewall/iptables
+ sys-fs/vzquota
+ sys-apps/iproute2"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install || die "make install failed"
+
+ # Provide a symlink for vz.conf (part 1 of fixing #138462)
+ dosym /etc/vz/vz.conf /etc/conf.d/vz
+
+ # Install gentoo specific init script
+ newinitd "${FILESDIR}"/vz-${PV}.initd vz
+}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}