summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-06-29 09:26:42 +0000
committerPeter Volkov <pva@gentoo.org>2010-06-29 09:26:42 +0000
commit70232c683d48fc118c7bdb5f48e72d0e3bd7627c (patch)
tree6488416f9780114713fc760b2e93bd7432312226 /sys-cluster/vzctl
parentstable x86, bug 325717 (diff)
downloadgentoo-2-70232c683d48fc118c7bdb5f48e72d0e3bd7627c.tar.gz
gentoo-2-70232c683d48fc118c7bdb5f48e72d0e3bd7627c.tar.bz2
gentoo-2-70232c683d48fc118c7bdb5f48e72d0e3bd7627c.zip
Version bump. Everything we did is finally upstream! Dropped old warn message from 9999 version.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog11
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.24.ebuild92
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild15
3 files changed, 103 insertions, 15 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 13e8a32bcced..2591da468657 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.68 2009/11/21 12:30:27 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.69 2010/06/29 09:26:42 pva Exp $
+
+*vzctl-3.0.24 (29 Jun 2010)
+
+ 29 Jun 2010; Peter Volkov <pva@gentoo.org> +vzctl-3.0.24.ebuild,
+ vzctl-9999.ebuild:
+ Version bump. Everything we did is finally upstream! Dropped old warn
+ message from 9999 version.
21 Nov 2009; Peter Volkov <pva@gentoo.org> -vzctl-3.0.22-r2.ebuild,
-files/vzctl-3.0.22-adjust-meminfo.patch,
diff --git a/sys-cluster/vzctl/vzctl-3.0.24.ebuild b/sys-cluster/vzctl/vzctl-3.0.24.ebuild
new file mode 100644
index 000000000000..15d0ef57037c
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.24.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.24.ebuild,v 1.1 2010/06/29 09:26:42 pva Exp $
+
+EAPI="2"
+
+inherit bash-completion eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion"
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+}
+
+src_compile() {
+ econf \
+ --localstatedir=/var \
+ --enable-cron \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ --enable-logrotate
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ local conf_without_OSTEMPLATE
+ for file in \
+ $(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ if ! grep '^OSTEMPLATE' $file > /dev/null; then
+ conf_without_OSTEMPLATE+=" $file"
+ fi
+ done
+
+ if [[ -n ${conf_without_OSTEMPLATE} ]]; then
+ ewarn
+ ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
+ ewarn "This means that any VEID.conf files without explicit or correct"
+ ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
+ ewarn "Please check the following configs:"
+ for file in ${conf_without_OSTEMPLATE}; do
+ ewarn "${file}"
+ done
+ ewarn
+ fi
+
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ elog "NOTE: Starting with vzctl-3.0.22 the mechanism for choosing the"
+ elog "interfaces to send ARP requests to has been improved (see description"
+ elog "of NEIGHBOUR_DEVS in vz.conf(5) man page). In case CT IP addresses"
+ elog "are not on the same subnet as HN IPs, it may lead to such CTs being"
+ elog "unreachable from the outside world."
+ elog
+ elog "The solution is to set up a device route(s) for the network your CTs are"
+ elog "in. For more details, see http://bugzilla.openvz.org/show_bug.cgi?id=771#c1"
+ elog
+ elog "The old vzctl behavior can be restored by setting NEIGHBOUR_DEVS to any"
+ elog 'value other than "detect" in /etc/vz/vz.conf.'
+}
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index 5e88f77d1a91..9739686ed99d 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.4 2009/11/06 13:12:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.5 2010/06/29 09:26:42 pva Exp $
EAPI="2"
@@ -53,17 +53,6 @@ src_install() {
pkg_postinst() {
bash-completion_pkg_postinst
- ewarn
- if has_version "<sys-cluster/vzctl-3.0.10"; then
- ewarn "The location of some vzctl files have changed. Most notably,"
- ewarn "CT configuration files and samples directory has changed from"
- ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
- ewarn "your CTs, please do the following:"
- ewarn
- ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
- ewarn
- fi
-
local conf_without_OSTEMPLATE
for file in \
$(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do