summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2012-03-31 05:04:47 +0000
committerPeter Volkov <pva@gentoo.org>2012-03-31 05:04:47 +0000
commit14e6fee570a71f85561ab04548637c4c71b84919 (patch)
tree473606d08d189dca7ff8d01e379fbc384836d3cc /sys-cluster/vzctl
parentold (diff)
downloadgentoo-2-14e6fee570a71f85561ab04548637c4c71b84919.tar.gz
gentoo-2-14e6fee570a71f85561ab04548637c4c71b84919.tar.bz2
gentoo-2-14e6fee570a71f85561ab04548637c4c71b84919.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog9
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.30.2.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index cea9dba9c4ea..bd632bed1b9d 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/vzctl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.87 2011/11/06 18:12:32 pva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.88 2012/03/31 05:04:47 pva Exp $
+
+*vzctl-3.0.30.2 (31 Mar 2012)
+
+ 31 Mar 2012; Peter Volkov <pva@gentoo.org> +vzctl-3.0.30.2.ebuild:
+ Version bump.
06 Nov 2011; Peter Volkov <pva@gentoo.org> -vzctl-3.0.28.3.ebuild,
-files/vzctl-3.0.28.3-vzeventd-stop.patch, vzctl-3.0.29.3.ebuild:
diff --git a/sys-cluster/vzctl/vzctl-3.0.30.2.ebuild b/sys-cluster/vzctl/vzctl-3.0.30.2.ebuild
new file mode 100644
index 000000000000..11b99893bc98
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.30.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.30.2.ebuild,v 1.1 2012/03/31 05:04:47 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo added in vzctl-3.0.24 (29 Jun 2010)
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}