summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-12 08:10:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-12 08:10:36 +0000
commit1867863fb03e390ac758e812db92a561dff0b5c7 (patch)
tree95268fcb61368dc54d3ea4da85fdd0ef3b48e9e8 /sys-cluster/torque
parentStable on ppc64 (diff)
downloadgentoo-2-1867863fb03e390ac758e812db92a561dff0b5c7.tar.gz
gentoo-2-1867863fb03e390ac758e812db92a561dff0b5c7.tar.bz2
gentoo-2-1867863fb03e390ac758e812db92a561dff0b5c7.zip
Ensure that torque directories exist always. keepdir is not safe on them either.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog7
-rw-r--r--sys-cluster/torque/torque-1.2.0_p1-r2.ebuild10
2 files changed, 15 insertions, 2 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index ae6632fec9d4..c965d471205d 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.13 2005/07/07 11:47:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.14 2005/07/12 08:10:36 robbat2 Exp $
+
+ 12 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ torque-1.2.0_p1-r2.ebuild:
+ Ensure that torque directories exist always. keepdir is not safe on them
+ either.
07 Jul 2005; Markus Rothe <corsair@gentoo.org> torque-1.2.0_p1-r2.ebuild:
added ~ppc64
diff --git a/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild b/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild
index 327df9957bde..35c942676040 100644
--- a/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild
+++ b/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild,v 1.4 2005/07/07 11:47:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild,v 1.5 2005/07/12 08:10:36 robbat2 Exp $
inherit flag-o-matic eutils
@@ -69,4 +69,12 @@ src_install() {
#newinitd ${FILESDIR}/pbs-init.d pbs
#newconfd ${FILESDIR}/pbs-conf.d pbs
dosym /usr/$(get_libdir)/pbs/libpbs.a /usr/$(get_libdir)/libpbs.a
+
+}
+
+pkg_postinst() {
+ # this file MUST exist for PBS/Torque to work
+ touch ${ROOT}/etc/pbs_environment
+ # likewise for these directories
+ mkdir -p ${ROOT}/usr/spool/PBS/{spool,mom_{priv/jobs,logs},sched_{priv,logs},server_priv/{jobs,queues,accounting}}
}