summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-04-28 17:47:48 +0000
committerSven Wegener <swegener@gentoo.org>2007-04-28 17:47:48 +0000
commit5d9fce243d4e004008a72133e875c77639698cc6 (patch)
treeee3aaf976f4b8b4f1a867d59bdd10eded75cd49b /sys-cluster/pvm
parentFix *initd, *confd and *envd calls (#173884, #174266) (diff)
downloadgentoo-2-5d9fce243d4e004008a72133e875c77639698cc6.tar.gz
gentoo-2-5d9fce243d4e004008a72133e875c77639698cc6.tar.bz2
gentoo-2-5d9fce243d4e004008a72133e875c77639698cc6.zip
Fix *initd, *confd and *envd calls (#173884, #174266)
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-cluster/pvm')
-rw-r--r--sys-cluster/pvm/ChangeLog6
-rw-r--r--sys-cluster/pvm/pvm-3.4.4-r1.ebuild7
-rw-r--r--sys-cluster/pvm/pvm-3.4.4-r2.ebuild7
-rw-r--r--sys-cluster/pvm/pvm-3.4.4-r3.ebuild7
4 files changed, 14 insertions, 13 deletions
diff --git a/sys-cluster/pvm/ChangeLog b/sys-cluster/pvm/ChangeLog
index d0dc5f88c2a8..e145157a7a94 100644
--- a/sys-cluster/pvm/ChangeLog
+++ b/sys-cluster/pvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/pvm
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/ChangeLog,v 1.34 2007/04/26 06:19:19 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/ChangeLog,v 1.35 2007/04/28 17:47:48 swegener Exp $
+
+ 28 Apr 2007; Sven Wegener <swegener@gentoo.org> pvm-3.4.4-r1.ebuild,
+ pvm-3.4.4-r2.ebuild, pvm-3.4.4-r3.ebuild:
+ Fix *initd, *confd and *envd calls (#173884, #174266)
26 Apr 2007; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Update for cluster herd split to hp-cluster and ha-cluster.
diff --git a/sys-cluster/pvm/pvm-3.4.4-r1.ebuild b/sys-cluster/pvm/pvm-3.4.4-r1.ebuild
index f08f72b10c6d..bb945d924a53 100644
--- a/sys-cluster/pvm/pvm-3.4.4-r1.ebuild
+++ b/sys-cluster/pvm/pvm-3.4.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r1.ebuild,v 1.12 2006/07/16 21:32:31 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r1.ebuild,v 1.13 2007/04/28 17:47:48 swegener Exp $
inherit eutils
@@ -42,8 +42,7 @@ src_install() {
touch 98pvm
echo PVM_ROOT=/usr/local/pvm3 >98pvm
echo PVM_ARCH=LINUX >>98pvm
- insinto /etc/env.d
- doins 98pvm
+ doenvd 98pvm
}
pkg_postinst() {
diff --git a/sys-cluster/pvm/pvm-3.4.4-r2.ebuild b/sys-cluster/pvm/pvm-3.4.4-r2.ebuild
index 38a6238a26d1..f140ec287cbe 100644
--- a/sys-cluster/pvm/pvm-3.4.4-r2.ebuild
+++ b/sys-cluster/pvm/pvm-3.4.4-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r2.ebuild,v 1.9 2006/07/16 21:32:31 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r2.ebuild,v 1.10 2007/04/28 17:47:48 swegener Exp $
inherit eutils
@@ -58,8 +58,7 @@ src_install() {
#environment variables:
echo PVM_ROOT=/usr/share/pvm3 > ${T}/98pvm
echo PVM_ARCH=$(${D}/usr/share/pvm3/lib/pvmgetarch) >> ${T}/98pvm
- insinto /etc/env.d
- doins ${T}/98pvm
+ doenvd ${T}/98pvm
}
pkg_postinst() {
diff --git a/sys-cluster/pvm/pvm-3.4.4-r3.ebuild b/sys-cluster/pvm/pvm-3.4.4-r3.ebuild
index c747f3094fd6..35728d585122 100644
--- a/sys-cluster/pvm/pvm-3.4.4-r3.ebuild
+++ b/sys-cluster/pvm/pvm-3.4.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r3.ebuild,v 1.4 2006/07/16 21:32:31 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.4-r3.ebuild,v 1.5 2007/04/28 17:47:48 swegener Exp $
inherit eutils
@@ -60,8 +60,7 @@ src_install() {
#environment variables:
echo PVM_ROOT=/usr/share/pvm3 > ${T}/98pvm
echo PVM_ARCH=$(${D}/usr/share/pvm3/lib/pvmgetarch) >> ${T}/98pvm
- insinto /etc/env.d
- doins ${T}/98pvm
+ doenvd ${T}/98pvm
}
pkg_postinst() {