summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-08-23 11:21:54 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-08-23 11:21:54 +0000
commite7f65225448a7fca627a4395e0ccdb871a51a2e0 (patch)
treec851a22574bc614650837bd181a02bd218f4f331 /sys-cluster/pacemaker
parentFix spelling in conf.d file wrt #275761 by Jeroen Roovers <jer@gentoo.org> (diff)
downloadgentoo-2-e7f65225448a7fca627a4395e0ccdb871a51a2e0.tar.gz
gentoo-2-e7f65225448a7fca627a4395e0ccdb871a51a2e0.tar.bz2
gentoo-2-e7f65225448a7fca627a4395e0ccdb871a51a2e0.zip
Fix building with glibc-2.16 wrt #432012 by Diego Elio Pettenò <flameeyes@gentoo.org>
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog8
-rw-r--r--sys-cluster/pacemaker/files/1.1.7-glibc2.16.patch13
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.7.ebuild4
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index 0fc37ffe901b..d5d8b606dcb5 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/pacemaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.22 2012/07/11 08:10:46 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.23 2012/08/23 11:21:54 xarthisius Exp $
+
+ 23 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/1.1.7-glibc2.16.patch, pacemaker-1.1.7.ebuild:
+ Fix building with glibc-2.16 wrt #432012 by Diego Elio Pettenò
+ <flameeyes@gentoo.org>
*pacemaker-1.0.12 (11 Jul 2012)
@@ -117,4 +122,3 @@
+pacemaker-1.0.8.ebuild, +files/pacemaker-1.0.8-asneeded.patch,
+files/pacemaker-1.0.8-installpaths.patch, +metadata.xml:
Initial import. Ebuild written by Tomáš Chvátal <scarabeus@gentoo.org>
-
diff --git a/sys-cluster/pacemaker/files/1.1.7-glibc2.16.patch b/sys-cluster/pacemaker/files/1.1.7-glibc2.16.patch
new file mode 100644
index 000000000000..73ffd0614c69
--- /dev/null
+++ b/sys-cluster/pacemaker/files/1.1.7-glibc2.16.patch
@@ -0,0 +1,13 @@
+Fix building with glibc-2.16
+
+https://bugs.gentoo.org/show_bug.cgi?id=432012
+--- a/mcp/pacemaker.h
++++ b/mcp/pacemaker.h
+@@ -21,6 +21,7 @@
+ #include <sys/param.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <sys/resource.h>
+
+ #include <stdint.h>
+
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild
index 8d31f01ca4c7..364c2a8fcbf7 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild,v 1.2 2012/05/30 14:55:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild,v 1.3 2012/08/23 11:21:54 xarthisius Exp $
EAPI=4
@@ -35,6 +35,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${PV}-glibc2.16.patch )
+
S="${WORKDIR}/ClusterLabs-${PN}-${MY_TREE}"
pkg_setup() {