summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-07-08 14:02:02 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-07-08 14:02:02 +0000
commit78ba13feac852a84b0da3cdce9e66af7274f3ee3 (patch)
tree2324acbc8649936a4a28c003e6aa432fa7da548b /sys-cluster/pacemaker
parentRestore pngpriv.h in pngtest.c because we are using apng patch from 1.4.7 wrt... (diff)
downloadgentoo-2-78ba13feac852a84b0da3cdce9e66af7274f3ee3.tar.gz
gentoo-2-78ba13feac852a84b0da3cdce9e66af7274f3ee3.tar.bz2
gentoo-2-78ba13feac852a84b0da3cdce9e66af7274f3ee3.zip
Drop unused eclasses, quotes, pacemaker -> PN
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog6
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.0.11.ebuild19
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.5.ebuild16
3 files changed, 24 insertions, 17 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index 2daa6b5e8b33..d067c5ce84e0 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/pacemaker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.13 2011/07/08 13:47:33 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.14 2011/07/08 14:02:02 xarthisius Exp $
+
+ 08 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> pacemaker-1.0.11.ebuild,
+ pacemaker-1.1.5.ebuild:
+ Drop unused eclasses, quotes, pacemaker -> PN
*pacemaker-1.1.5 (08 Jul 2011)
diff --git a/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild b/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild
index 9c7b18451cec..61bae38013b9 100644
--- a/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild,v 1.1 2011/07/05 07:28:53 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.0.11.ebuild,v 1.2 2011/07/08 14:02:02 xarthisius Exp $
EAPI="2"
-MY_PN="Pacemaker"
-MY_P="${MY_PN}-${PV}"
+MY_PN=Pacemaker
+MY_P=${MY_PN}-${PV}
PYTHON_DEPEND="2"
-inherit python autotools multilib eutils base flag-o-matic
+
+inherit autotools base python
DESCRIPTION="Pacemaker CRM"
HOMEPAGE="http://www.clusterlabs.org/"
@@ -18,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="+ais heartbeat smtp snmp static-libs"
-RDEPEND="
+DEPEND="
dev-libs/libxslt
sys-cluster/cluster-glue
sys-cluster/resource-agents
@@ -28,14 +29,14 @@ RDEPEND="
snmp? ( net-analyzer/net-snmp )
!heartbeat? ( !ais? ( sys-cluster/openais ) )
"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-1.0.10-asneeded.patch"
"${FILESDIR}/${PN}-1.0.10-installpaths.patch"
)
-S="${WORKDIR}/${MY_PN}-1-0-${MY_P}"
+S=${WORKDIR}/${MY_PN}-1-0-${MY_P}
pkg_setup() {
if ! use ais && ! use heartbeat; then
@@ -56,7 +57,9 @@ src_prepare() {
src_configure() {
local myopts=""
- use heartbeat || use ais || myopts="--with-ais"
+ if ! use ais && ! use heartbeat; then
+ myopts="--with-ais"
+ fi
# appends lib to localstatedir automatically
econf \
--localstatedir=/var \
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild
index 3c0247b032d6..bf42f1e9d2da 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild,v 1.1 2011/07/08 13:47:33 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild,v 1.2 2011/07/08 14:02:02 xarthisius Exp $
EAPI=3
-inherit autotools base eutils flag-o-matic multilib python
+inherit autotools base python
-MY_PN="Pacemaker"
-MY_P="${MY_PN}-${PV}"
+MY_PN=Pacemaker
+MY_P=${MY_PN}-${PV}
PYTHON_DEPEND="2"
DESCRIPTION="Pacemaker CRM"
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="acl heartbeat smtp snmp static-libs"
-RDEPEND="
+DEPEND="
dev-libs/libxslt
sys-cluster/corosync
sys-cluster/cluster-glue
@@ -28,7 +28,7 @@ RDEPEND="
smtp? ( net-libs/libesmtp )
snmp? ( net-analyzer/net-snmp )
"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-autotools.patch"
@@ -67,9 +67,9 @@ src_configure() {
src_install() {
base_src_install
- newinitd "${FILESDIR}/pacemaker.initd" pacemaker || die
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
insinto /etc/corosync/service.d
- newins "${FILESDIR}/pacemaker.service" pacemaker || die
+ newins "${FILESDIR}/${PN}.service" ${PN} || die
}
pkg_postinst() {