summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-01-18 11:51:54 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-01-18 11:51:54 +0000
commit69ebb1aa9dff66845d27cf54c51c7b56cc7126f9 (patch)
tree96c8a0e7618af294df285ffc6ac244cb064f0b62 /sys-cluster/pacemaker
parentfix #445686, drop old wrt #376983 (diff)
downloadgentoo-2-69ebb1aa9dff66845d27cf54c51c7b56cc7126f9.tar.gz
gentoo-2-69ebb1aa9dff66845d27cf54c51c7b56cc7126f9.tar.bz2
gentoo-2-69ebb1aa9dff66845d27cf54c51c7b56cc7126f9.zip
Do not keepdir /var/run/crm wrt #449878
(Portage version: 2.1.11.41/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog10
-rw-r--r--sys-cluster/pacemaker/files/pacemaker.initd7
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.8-r1.ebuild86
3 files changed, 99 insertions, 4 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index ed2219ed7bcd..e3c055091cbd 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/pacemaker
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.26 2012/11/14 17:24:22 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.27 2013/01/18 11:51:54 ultrabug Exp $
+
+*pacemaker-1.1.8-r1 (18 Jan 2013)
+
+ 18 Jan 2013; Ultrabug <ultrabug@gentoo.org> +pacemaker-1.1.8-r1.ebuild,
+ files/pacemaker.initd:
+ Do not keepdir /var/run/crm wrt #449878
14 Nov 2012; Jeroen Roovers <jer@gentoo.org> pacemaker-1.1.8.ebuild:
Marked ~hppa (bug #442408).
diff --git a/sys-cluster/pacemaker/files/pacemaker.initd b/sys-cluster/pacemaker/files/pacemaker.initd
index 4231425f8874..98bc0d0e0e88 100644
--- a/sys-cluster/pacemaker/files/pacemaker.initd
+++ b/sys-cluster/pacemaker/files/pacemaker.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/files/pacemaker.initd,v 1.1 2011/02/21 14:39:28 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/files/pacemaker.initd,v 1.2 2013/01/18 11:51:54 ultrabug Exp $
PIDFILE=/var/run/pacemaker.pid
@@ -13,6 +13,9 @@ depend() {
start() {
nc=0
ebegin "Starting Pacemaker Cluster Manager"
+
+ checkpath -d -m 0750 -o hacluster:haclient /var/run/crm
+
einfon "Waiting for Corosync startup ."
while true; do
/usr/sbin/corosync-cfgtool -s &>/dev/null && break
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.8-r1.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..642afe4f773f
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-1.1.8-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.8-r1.ebuild,v 1.1 2013/01/18 11:51:54 ultrabug Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit autotools base python
+
+MY_PN=Pacemaker
+MY_P=${MY_PN}-${PV}
+MY_TREE="1f8858c"
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="https://github.com/ClusterLabs/${PN}/tarball/${MY_P} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+REQUIRED_USE="cman? ( !heartbeat )"
+IUSE="acl cman heartbeat smtp snmp static-libs"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-cluster/cluster-glue
+ >=sys-cluster/libqb-0.14.0
+ sys-cluster/resource-agents
+ cman? ( sys-cluster/cman )
+ heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
+ !heartbeat? ( sys-cluster/corosync )
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="sys-cluster/crmsh"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-backwards_compatibility.patch
+ )
+
+S="${WORKDIR}/ClusterLabs-${PN}-${MY_TREE}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ sed -i -e "/ggdb3/d" configure.ac || die
+ sed -e "s:<glib/ghash.h>:<glib.h>:" \
+ -i lib/ais/plugin.c || die
+ eautoreconf
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myopts=""
+ use heartbeat || myopts="--with-ais"
+ # appends lib to localstatedir automatically
+ econf \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ $(use_with acl) \
+ $(use_with cman cs-quorum) \
+ $(use_with cman cman) \
+ $(use_with heartbeat) \
+ $(use_with smtp esmtp) \
+ $(use_with snmp) \
+ $(use_enable static-libs static) \
+ ${myopts}
+}
+
+src_install() {
+ base_src_install
+ rm -rf "${D}"/var/run
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ if has_version "<sys-cluster/corosync-2.0"; then
+ insinto /etc/corosync/service.d
+ newins "${FILESDIR}/${PN}.service" ${PN} || die
+ fi
+}