summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-11-09 08:20:26 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-11-09 08:20:26 +0000
commit377c0effd86cd32081c7e7c237ad7073deb2e52b (patch)
treeca9fa00959f51aab8b73d83b37eae7c9e1ec727e /sys-cluster/pacemaker
parentnew sys-cluster/crmsh ebuild (diff)
downloadgentoo-2-377c0effd86cd32081c7e7c237ad7073deb2e52b.tar.gz
gentoo-2-377c0effd86cd32081c7e7c237ad7073deb2e52b.tar.bz2
gentoo-2-377c0effd86cd32081c7e7c237ad7073deb2e52b.zip
sys-cluster/pacemaker bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog9
-rw-r--r--sys-cluster/pacemaker/files/1.1.8-backwards_compatibility.patch36
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.8.ebuild (renamed from sys-cluster/pacemaker/pacemaker-1.1.6.1.ebuild)31
3 files changed, 57 insertions, 19 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index d5d8b606dcb5..4560a7208892 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pacemaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.23 2012/08/23 11:21:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.24 2012/11/09 08:20:25 ultrabug Exp $
+
+*pacemaker-1.1.8 (09 Nov 2012)
+
+ 09 Nov 2012; Ultrabug <ultrabug@gentoo.org>
+ +files/1.1.8-backwards_compatibility.patch, -pacemaker-1.1.6.1.ebuild,
+ +pacemaker-1.1.8.ebuild:
+ Version bump with fixed backwards compatibility. Drop old.
23 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org>
+files/1.1.7-glibc2.16.patch, pacemaker-1.1.7.ebuild:
diff --git a/sys-cluster/pacemaker/files/1.1.8-backwards_compatibility.patch b/sys-cluster/pacemaker/files/1.1.8-backwards_compatibility.patch
new file mode 100644
index 000000000000..d4a5780c0142
--- /dev/null
+++ b/sys-cluster/pacemaker/files/1.1.8-backwards_compatibility.patch
@@ -0,0 +1,36 @@
+--- a/lib/cluster/legacy.c 2012-11-08 11:55:09.297354491 +0100
++++ b/lib/cluster/legacy.c 2012-11-08 11:54:57.507587115 +0100
+@@ -1362,17 +1362,27 @@
+ /* If we can still talk to our peer process on that node,
+ * then its also part of the corosync membership
+ */
+- crm_trace("%s: processes=%.16x", node->uname, node->processes);
++ crm_trace("%s: processes=%.8x", node->uname, node->processes);
+ return TRUE;
+
+- } else if(is_classic_ais_cluster() && (node->processes & crm_proc_plugin) == 0) {
+- crm_trace("%s: processes=%.16x", node->uname, node->processes);
+- return FALSE;
++ } else if(is_classic_ais_cluster()) {
++ if(node->processes < crm_proc_none) {
++ crm_debug("%s: unknown process list, assuming active for now", node->uname);
++ return TRUE;
++
++ } else if(is_set(node->processes, crm_proc_none)) {
++ crm_debug("%s: all processes are inactive", node->uname);
++ return FALSE;
++
++ } else if(is_not_set(node->processes, crm_proc_plugin)) {
++ crm_trace("%s: processes=%.8x", node->uname, node->processes);
++ return FALSE;
++ }
+ }
+
+ proc = text2proc(crm_system_name);
+- if(proc != crm_proc_none && (node->processes & proc) == 0) {
+- crm_trace("%s: proc %.16x not in %.16x", node->uname, proc, node->processes);
++ if(proc > crm_proc_none && (node->processes & proc) == 0) {
++ crm_trace("%s: proc %.8x not in %.8x", node->uname, proc, node->processes);
+ return FALSE;
+ }
+
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.6.1.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.8.ebuild
index 62720a8101e6..eee9228c54b2 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.6.1.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.6.1.ebuild,v 1.3 2012/05/30 14:55:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.8.ebuild,v 1.1 2012/11/09 08:20:25 ultrabug Exp $
EAPI=4
@@ -10,7 +10,7 @@ inherit autotools base python
MY_PN=Pacemaker
MY_P=${MY_PN}-${PV}
-MY_TREE="0c7312c"
+MY_TREE="1f8858c"
DESCRIPTION="Pacemaker CRM"
HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
@@ -18,7 +18,7 @@ SRC_URI="https://github.com/ClusterLabs/${PN}/tarball/${MY_P} -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
+KEYWORDS="~amd64 ~x86"
REQUIRED_USE="cman? ( !heartbeat )"
IUSE="acl cman heartbeat smtp snmp static-libs"
@@ -26,6 +26,8 @@ DEPEND="
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
sys-cluster/cluster-glue
+ >=sys-cluster/libqb-0.14.0
+ sys-cluster/crmsh
sys-cluster/resource-agents
cman? ( sys-cluster/cman )
heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
@@ -35,6 +37,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PV}-backwards_compatibility.patch
+ )
+
S="${WORKDIR}/ClusterLabs-${PN}-${MY_TREE}"
pkg_setup() {
@@ -72,19 +78,8 @@ src_configure() {
src_install() {
base_src_install
newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
- insinto /etc/corosync/service.d
- newins "${FILESDIR}/${PN}.service" ${PN} || die
-}
-
-pkg_postinst() {
- elog "This version of Pacemaker uses the new MCP feature"
- elog "and the v1 plugin for CoroSync. Read [1] for more info."
- elog
- elog "To start the Pacemaker Cluster Manager, run:"
- elog "/etc/init.d/pacemaker start"
- elog
- elog "[1] http://theclusterguy.clusterlabs.org/post/907043024/introducing-the-pacemaker-master-control-process-for"
- elog
- elog "Note: sys-cluster/openais is no longer a hard dependency of ${P},"
- elog "so you may need to install it yourself to suit your needs."
+ if has_version "<sys-cluster/corosync-2.0"; then
+ insinto /etc/corosync/service.d
+ newins "${FILESDIR}/${PN}.service" ${PN} || die
+ fi
}