summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-11-04 21:45:00 +0000
committerMichael Imhof <tantive@gentoo.org>2002-11-04 21:45:00 +0000
commitecc5f5b4a4596bebb500f685d6edc0361431cd4f (patch)
tree12a27e83f3323e0eb76953563bf963bf7e51b45a /sys-cluster/openmosix-user
parentUpdated ebuild to install unarj in /usr/bin instead of a non-executable (diff)
downloadgentoo-2-ecc5f5b4a4596bebb500f685d6edc0361431cd4f.tar.gz
gentoo-2-ecc5f5b4a4596bebb500f685d6edc0361431cd4f.tar.bz2
gentoo-2-ecc5f5b4a4596bebb500f685d6edc0361431cd4f.zip
forgot some files :-)
Diffstat (limited to 'sys-cluster/openmosix-user')
-rw-r--r--sys-cluster/openmosix-user/ChangeLog41
-rw-r--r--sys-cluster/openmosix-user/openmosix-user-0.2.0.ebuild70
2 files changed, 111 insertions, 0 deletions
diff --git a/sys-cluster/openmosix-user/ChangeLog b/sys-cluster/openmosix-user/ChangeLog
new file mode 100644
index 000000000000..315796dff04a
--- /dev/null
+++ b/sys-cluster/openmosix-user/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for sys-apps/openmosix-user
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/ChangeLog,v 1.1 2002/11/04 21:45:00 tantive Exp $
+
+ 04 Nov 2002; Michael Imhof <tantive@gentoo.org>
+ Moved to sys-cluster/openmosix-user
+
+* openmosix-user-0.2.4-r4 (17 Oct 2002)
+
+ 17 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Sometimes the old method of creating the Makefile could result
+ in a Makefile of zero length. Fixed and closed #8816.
+
+* openmosix-user-0.2.4-r3 (14 Oct 2002)
+
+ 14 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Put the autodiscovery daemon (omdiscd) into non-alpha-mode.
+
+* openmosix-user-0.2.4-r2 (10 Oct 2002)
+
+ 10 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Enabled the autodiscovery daemon (omdiscd).
+
+* openmosix-user-0.2.4-r1 (30 Aug 2002)
+
+ 30 Aug 2002; Michael Imhof <tantive@gentoo.org>
+ Created symlinks in /bin for /usr/bin/[mmon/migrate/mosctl/mosrun] to make
+ scripts like nomig run.
+
+* openmosix-user-0.2.4 (19 Aug 2002)
+
+ 19 Aug 2002; Michael Imhof <tantive@gentoo.org>:
+ Version bump to 0.2.4 for new openmosix-sources
+
+* openmosix-user-0.2.0 (23 Jun 2002)
+
+ 21 Jul 2002; Mark Guertin <gerk@gentoo.org>:
+ updated keywords (-ppc), no mosix works on ppc
+
+ 23 Jun 2002; Brandon Low <lostlogic@gentoo.org> openmosix-0.2.0.ebuild:
+ Version bump to 0.2.0 for new openmosix-sources
diff --git a/sys-cluster/openmosix-user/openmosix-user-0.2.0.ebuild b/sys-cluster/openmosix-user/openmosix-user-0.2.0.ebuild
new file mode 100644
index 000000000000..78e0d60a37e6
--- /dev/null
+++ b/sys-cluster/openmosix-user/openmosix-user-0.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/openmosix-user-0.2.0.ebuild,v 1.1 2002/11/04 21:45:00 tantive Exp $
+
+S=${WORKDIR}/openMosixUserland-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openMosixUserland-${PV}.tar.gz"
+HOMEPAGE="http://www.openmosix.com/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.17"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ sys-devel/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat > configuration << EOF
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\$(OPENMOSIX)/include ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+# #use perl, find and xargs to convert /usr/man references to /usr/share/man (FHS)
+# find . -iname Makefile | xargs perl -pi.orig -e "s:INSTALLDIR\)/man:INSTALLDIR)/share/man:g"
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install () {
+ sed -e "s:INSTALLEXTRADIR:INSTALLBASEDIR:" moslib/Makefile > moslib/Makefile.hacked
+ mv moslib/Makefile.hacked moslib/Makefile
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ make INSTALLBASEDIR=${D}usr \
+ INSTALLEXTRADIR=${D}usr/share \
+ DESTDIR=${D} \
+ INSTALLDIR=${D}usr \
+ install
+
+ dodoc COPYING README
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/mosix.map and then type:"
+ einfo " # rc-update add openmosix default"
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.17-openmosix-r1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.17)"
+ einfo
+}