summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-02-17 16:48:49 +0000
committerSimon Stelling <blubb@gentoo.org>2006-02-17 16:48:49 +0000
commit3463b44746c11a0c21b86382721398896417b96f (patch)
tree68681d377e52eec927423c6eed12a606ceae5063 /sys-cluster/openmosix-3dmon
parentremove unneeded file (diff)
downloadgentoo-2-3463b44746c11a0c21b86382721398896417b96f.tar.gz
gentoo-2-3463b44746c11a0c21b86382721398896417b96f.tar.bz2
gentoo-2-3463b44746c11a0c21b86382721398896417b96f.zip
no need to bzip smallish patches
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-cluster/openmosix-3dmon')
-rw-r--r--sys-cluster/openmosix-3dmon/ChangeLog10
-rw-r--r--sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch165
-rw-r--r--sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch.bz2bin1162 -> 0 bytes
-rw-r--r--sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild8
4 files changed, 177 insertions, 6 deletions
diff --git a/sys-cluster/openmosix-3dmon/ChangeLog b/sys-cluster/openmosix-3dmon/ChangeLog
index e4b3b2524382..4365a5cadd07 100644
--- a/sys-cluster/openmosix-3dmon/ChangeLog
+++ b/sys-cluster/openmosix-3dmon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmosix-3dmon
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-3dmon/ChangeLog,v 1.4 2004/07/01 21:48:17 eradicator Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-3dmon/ChangeLog,v 1.5 2006/02/17 16:47:16 blubb Exp $
+
+ 17 Feb 2006; Simon Stelling <blubb@gentoo.org>
+ +files/openmosix-3dmon-0.2.1-trivial.patch,
+ -files/openmosix-3dmon-0.2.1-trivial.patch.bz2,
+ openmosix-3dmon-0.2.1.ebuild:
+ no need to bzip smallish patches
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
openmosix-3dmon-0.2.1.ebuild:
diff --git a/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch b/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch
new file mode 100644
index 000000000000..c71636e9f871
--- /dev/null
+++ b/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch
@@ -0,0 +1,165 @@
+diff -Nru 3dmon-0.2.1/3dmosmon/3dmosmon.cpp 3dmon-0.2.1-fix/3dmosmon/3dmosmon.cpp
+--- 3dmon-0.2.1/3dmosmon/3dmosmon.cpp 2002-11-15 20:03:23.000000000 +0300
++++ 3dmon-0.2.1-fix/3dmosmon/3dmosmon.cpp 2004-03-21 21:42:22.805031659 +0300
+@@ -457,7 +457,8 @@
+ switch (key)
+ {
+ case 'q': kill(kpid, SIGKILL); Barmanager.quit(); break;
+-
++ case 27 : kill(kpid, SIGKILL); Barmanager.quit(); break;
++
+ case 'r': Barmanager.ToggleSpin(); break;
+
+ case 'w':
+@@ -655,7 +656,7 @@
+ }
+
+
+-void main(int argc, char** argv)
++int main(int argc, char** argv)
+ {
+
+ ParseArguments(argc, argv);
+diff -Nru 3dmon-0.2.1/3dmosmon/barmanager.h 3dmon-0.2.1-fix/3dmosmon/barmanager.h
+--- 3dmon-0.2.1/3dmosmon/barmanager.h 2002-11-09 17:30:32.000000000 +0300
++++ 3dmon-0.2.1-fix/3dmosmon/barmanager.h 2004-03-21 21:36:40.892913624 +0300
+@@ -27,7 +27,7 @@
+
+ #include "rand.h"
+ #include "spin.h"
+-#include "map.h"
++#include <map>
+
+ #define LOAD 1 //values for display mode
+ #define MEM 2
+@@ -68,11 +68,11 @@
+ private:
+ //TwoDMosixMap map;
+ // map MosixMap;
+- list <CObject *> ObjectList;
+- list<CObject *> ::iterator ObjectIter;
++ std::list <CObject *> ObjectList;
++ std::list <CObject *> ::iterator ObjectIter;
+
+- list <bar_record> BarList;
+- list <bar_record> ::iterator BarIter;
++ std::list <bar_record> BarList;
++ std::list <bar_record> ::iterator BarIter;
+
+ int Spin;
+
+diff -Nru 3dmon-0.2.1/3dmosmon/materials.h 3dmon-0.2.1-fix/3dmosmon/materials.h
+--- 3dmon-0.2.1/3dmosmon/materials.h 2002-10-11 15:57:04.000000000 +0400
++++ 3dmon-0.2.1-fix/3dmosmon/materials.h 2004-03-21 21:36:40.892913624 +0300
+@@ -29,20 +29,20 @@
+ {1.0, 1.0, 1.0, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {1.0, 1.0, 1.0, 1.0},
+- {20.0}
++ 20.0
+ };
+
+ static material_struct lensMaterials = {
+ {0.1, 0.1, 0.1, 1.0},
+ {0.1, 0.1, 0.1, 1.0},
+ {1.0, 1.0, 1.0, 1.0},
+- {20.0}
++ 20.0
+ };
+ static material_struct redMaterials = {
+ {1.0, 0.0, 0.0, 0.4},
+ {0.0, 0.0, 0.0, 0.4},
+ {0.0, 0.0, 0.0, 0.4},
+- {20.0}
++ 20.0
+ };
+
+
+@@ -50,14 +50,14 @@
+ {0.0, 0.6, 0.2, 0.4},
+ {0.0, 0.0, 0.0, 0.4},
+ {0.3, 0.3, 0.3, 0.4},
+- {20.0}
++ 20.0
+ };
+
+ static material_struct blueMaterials = {
+ {0.0, 0.0, 1.0, 0.4},
+ {0.0, 0.0, 0.0, 0.4},
+ {0.6, 0.6, 0.8, 0.4},
+- {20.0}
++ 20.0
+ };
+
+
+@@ -65,7 +65,7 @@
+ {1.0, 1.0, 0.0, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.8, 0.8, 0.6, 1.0},
+- {25.0}
++ 25.0
+
+ };
+
+@@ -74,7 +74,7 @@
+ {1.0, 0.75, 0.5, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.8, 0.8, 0.6, 1.0},
+- {25.0}
++ 25.0
+
+ };
+
+@@ -83,35 +83,35 @@
+ {0.0, 0.3, 0.0, 0.3},
+ {1.0, 1.0, 1.0, 0.3},
+ {0.2, 0.2, 0.2, 0.3},
+- {30.0}
++ 30.0
+ };
+
+ static material_struct groundMaterials = {
+ {0.0, 0.3, 0.0, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.6, 0.8, 0.6, 1.0},
+- {0.0}
++ 0.0
+ };
+
+ static material_struct brownMaterials = {
+ {0.4, 0.24, 0.11, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.3, 0.3, 0.3, 1.0},
+- {35.0}
++ 35.0
+ };
+
+ static material_struct moonMaterials = {
+ {0.5, 0.5, 0.6, 1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.6, 0.6, 0.8, 1.0},
+- {20.0}
++ 20.0
+ };
+
+ static material_struct sunMaterials = {
+ {0.75, 0.5, 0.0,1.0},
+ {0.0, 0.0, 0.0, 1.0},
+ {0.6, 0.6, 0.8, 1.0},
+- {20.0}
++ 20.0
+ };
+
+
+diff -Nru 3dmon-0.2.1/3dmosmon/objects.cpp 3dmon-0.2.1-fix/3dmosmon/objects.cpp
+--- 3dmon-0.2.1/3dmosmon/objects.cpp 2002-11-04 22:13:04.000000000 +0300
++++ 3dmon-0.2.1-fix/3dmosmon/objects.cpp 2004-03-21 21:46:31.954585523 +0300
+@@ -314,7 +314,7 @@
+ glutSolidCone(cone_data.base, cone_data.height, (int)cone_data.stacks, (int)cone_data.slices);
+
+ glFlush();
+-// glEnd();
++ glEnd();
+ glLoadIdentity();
+ glPopMatrix();
+ }
diff --git a/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch.bz2 b/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch.bz2
deleted file mode 100644
index 1466176108e2..000000000000
--- a/sys-cluster/openmosix-3dmon/files/openmosix-3dmon-0.2.1-trivial.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild b/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild
index 5e78d752ce19..68fd2f2474fb 100644
--- a/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild
+++ b/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild,v 1.5 2004/07/15 03:03:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-3dmon/openmosix-3dmon-0.2.1.ebuild,v 1.6 2006/02/17 16:47:16 blubb Exp $
inherit eutils
@@ -19,8 +19,8 @@ IUSE=""
src_unpack() {
unpack ${A}
- cd ${S} && \
- epatch ${FILESDIR}/${P}-trivial.patch.bz2 || die "Failed to patch the source."
+ cd ${S} && \
+ epatch ${FILESDIR}/${P}-trivial.patch || die "Failed to patch the source."
}
src_compile() {