summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-12 04:59:32 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-12 04:59:32 +0000
commitab53dd10d5922bfba8b0571f6a1ba4c01d1e46be (patch)
tree665e38193b7fb71beebc216c61df784c803f5b94 /sys-cluster/mpich2
parentadded one more for mpich2 (diff)
downloadgentoo-2-ab53dd10d5922bfba8b0571f6a1ba4c01d1e46be.tar.gz
gentoo-2-ab53dd10d5922bfba8b0571f6a1ba4c01d1e46be.tar.bz2
gentoo-2-ab53dd10d5922bfba8b0571f6a1ba4c01d1e46be.zip
finally killed the soname bug, added some additional configure options
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/ChangeLog7
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.3-soname.patch14
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild30
3 files changed, 41 insertions, 10 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index a4193d90a3d4..8a5890f8e819 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.8 2006/06/28 07:32:39 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.9 2006/07/12 04:59:31 nerdboy Exp $
+
+ 12 Jul 2006; Steve Arnold <nerdboy@gentoo.org>
+ files/mpich2-1.0.3-soname.patch, mpich2-1.0.3-r1.ebuild:
+ Finally killed the soname bug, added some additional configure options,
+ and made libaio a dependency for romio support (also fixed libaio).
28 Jun 2006; Steve Arnold <nerdboy@gentoo.org> mpich2-1.0.3-r1.ebuild:
reverted to original (and standard) library location
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.3-soname.patch b/sys-cluster/mpich2/files/mpich2-1.0.3-soname.patch
index cd8f19e2f73f..37aabe0ec92f 100644
--- a/sys-cluster/mpich2/files/mpich2-1.0.3-soname.patch
+++ b/sys-cluster/mpich2/files/mpich2-1.0.3-soname.patch
@@ -13,7 +13,7 @@
# Use syntax that works in both Make and the shell
#C_LINK_SHL='${CC} -shared -Wl,-r'
- C_LINK_SHL='${CC} -shared'
-+ C_LINK_SHL='${CC} -shared -Wl,-soname,lib$MPILIBNAME.$SHLIB_EXT.0.0'
++ C_LINK_SHL='${CC} -shared -Wl,-soname'
# For example, include the libname as ${LIBNAME_SHL}
#C_LINK_SHL='${CC} -shared -Wl,-h,<finallibname>'
# May need -fPIC
@@ -22,3 +22,15 @@
C_LINKPATH_SHL="-Wl,-rpath -Wl,"
# We need to test that this isn't osx. The following is a
# simple hack
+ esac
+--- src/util/createshlib.in.orig 2006-07-11 19:52:47.000000000 -0700
++++ src/util/createshlib.in 2006-07-11 19:56:09.000000000 -0700
+@@ -172,7 +172,7 @@
+
+ *)
+ # This is the default model
+- $Show ${C_LINK_SHL} -o $srclibbase.$SHLIB_EXT .tmp/*.o
++ $Show ${C_LINK_SHL} -Wl,$srclibbase.$SHLIB_EXT.0 -o $srclibbase.$SHLIB_EXT .tmp/*.o
+ ;;
+ esac
+
diff --git a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
index 8e470db74074..bfc6f134b865 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.2 2006/06/28 07:32:39 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.3 2006/07/12 04:59:31 nerdboy Exp $
inherit fortran distutils eutils autotools kde-functions toolchain-funcs
@@ -12,7 +12,7 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
# need more arches in here, like sparc...
-IUSE="crypt cxx doc debug fortran mpe mpe-sdk threads"
+IUSE="crypt cxx doc debug fortran mpe mpe-sdk romio threads"
PROVIDE="virtual/mpi"
DEPEND="virtual/libc
@@ -22,7 +22,8 @@ DEPEND="virtual/libc
sys-apps/coreutils
dev-lang/perl
sys-devel/gcc
- mpe-sdk? ( >=virtual/jdk-1.4.2 )
+ mpe-sdk? ( dev-java/ibm-jdk-bin )
+ romio? ( >=dev-libs/libaio-0.3.106 )
>=dev-lang/python-2.3"
RDEPEND="${DEPEND}
crypt? ( net-misc/openssh )
@@ -55,18 +56,20 @@ src_unpack() {
unpack ${A}
cd ${S}
need-autoconf 2.5
- epatch ${FILESDIR}/${P}-soname.patch || die "soname patch failed"
ebegin "Reconfiguring"
find . -name configure -print | xargs rm
./maint/updatefiles
use mpe-sdk && ./src/mpe2/maint/updatefiles
eend
epatch ${FILESDIR}/${P}-make.patch || die "make patch failed"
+ # damn, have to patch the createshlib script here...
+ epatch ${FILESDIR}/${P}-soname.patch || die "soname patch failed"
#epatch ${FILESDIR}/${P}-make-test.patch || die "make test patch failed"
}
src_compile() {
export LDFLAGS='-Wl,-z,now'
+
local RSHCOMMAND
if use crypt ; then
@@ -81,20 +84,30 @@ src_compile() {
if ! use debug ; then
myconf="${myconf} --enable-fast --enable-g=none"
else
- myconf="${myconf} --enable-g=dbg --enable-debuginfo"
+ myconf="${myconf} --enable-g=dbg --enable-debuginfo \
+ --enable-error-messages=all"
fi
if ! use mpe-sdk ; then
myconf="${myconf} --enable-graphics=no --enable-rlog=no \
--enable-clog=no --enable-slog2=no"
fi
+
use mpe && MPE_SRC_DIR=${S}/src/mpe2
+ if use threads ; then
+ myconf="${myconf} --with-thread-package=pthreads"
+ else
+ myconf="${myconf} --with-thread-package=none"
+ fi
+
./configure --prefix=/usr --exec-prefix=/usr \
- --enable-sharedlibs=gcc \
+ --enable-sharedlibs=gcc --enable-nmpi-as-mpi \
+ --enable-error-checking=runtime --enable-timing=runtime \
${myconf} \
$(use_enable cxx) \
$(use_enable mpe) \
+ $(use_enable romio) \
$(use_enable threads) \
--includedir=/usr/include \
--libdir=/usr/$(get_libdir) \
@@ -115,12 +128,13 @@ src_compile() {
fi
# parallel makes are currently broken, so no emake...
- make dependencies
+ #make dependencies
make || die "make failed"
if has test ${FEATURES} ; then
# get setup for src_test
- export LDFLAGS='-L../../lib'
+ #export LDFLAGS='-L../../lib'
+ export LD_LIBRARY_PATH=${S}/lib:$LD_LIBRARY_PATH
cd ${S}/test/mpi
#make clean || die "make clean failed"
echo