summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
commit4d45bb836cbad96a1f725391bd247bb9ac563072 (patch)
tree1eb91cbf0a34463ac2f70613fd1fdcecac40c958 /sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
parentVersion bump, now supports symlinks for ex, view, and man pages. (diff)
downloadgentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.tar.gz
gentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.tar.bz2
gentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.zip
(#148719) Use WANT_AUTOCONF instead of need-autoconf() from kde-functions.eclass.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild')
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
index 54627a86def5..6a611cedc159 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.5 2006/08/28 16:45:22 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.6 2006/09/24 18:15:25 dberkholz Exp $
-inherit fortran distutils eutils autotools kde-functions toolchain-funcs
+inherit fortran distutils eutils autotools toolchain-funcs
DESCRIPTION="MPICH2 - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
@@ -57,7 +57,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- need-autoconf 2.5
ebegin "Reconfiguring"
find . -name configure -print | xargs rm
./maint/updatefiles
@@ -103,9 +102,14 @@ src_compile() {
myconf="${myconf} --with-thread-package=none"
fi
- ./configure --prefix=/usr --exec-prefix=/usr \
- --enable-sharedlibs=gcc --enable-nmpi-as-mpi \
- --enable-error-checking=runtime --enable-timing=runtime \
+ WANT_AUTOCONF="2.5" \
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --enable-sharedlibs=gcc \
+ --enable-nmpi-as-mpi \
+ --enable-error-checking=runtime \
+ --enable-timing=runtime \
${myconf} \
$(use_enable cxx) \
$(use_enable mpe) \