summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-06-29 13:55:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-06-29 13:55:09 +0000
commiteeda69a16e811b4ff9c8a25c2c165e8c06740d10 (patch)
tree9366b6276049b59dbeac06c53b38de5749af35f4 /sys-cluster/maui
parentReadd dev-ruby/ruby-gtksourceview dependency as its latest version got its de... (diff)
downloadgentoo-2-eeda69a16e811b4ff9c8a25c2c165e8c06740d10.tar.gz
gentoo-2-eeda69a16e811b4ff9c8a25c2c165e8c06740d10.tar.bz2
gentoo-2-eeda69a16e811b4ff9c8a25c2c165e8c06740d10.zip
[sys-cluster/maui] Add new init.d
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/maui')
-rw-r--r--sys-cluster/maui/ChangeLog8
-rw-r--r--sys-cluster/maui/files/maui.initd45
-rw-r--r--sys-cluster/maui/maui-3.3.1-r1.ebuild (renamed from sys-cluster/maui/maui-3.3.1.ebuild)3
3 files changed, 54 insertions, 2 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index 5db119aea3da..659fccf05405 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/maui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.17 2011/03/05 10:29:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.18 2011/06/29 13:55:09 alexxy Exp $
+
+*maui-3.3.1-r1 (29 Jun 2011)
+
+ 29 Jun 2011; Alexey Shvetsov <alexxy@gentoo.org> -maui-3.3.1.ebuild,
+ +maui-3.3.1-r1.ebuild, +files/maui.initd:
+ Add init.d
*maui-3.3.1 (05 Mar 2011)
diff --git a/sys-cluster/maui/files/maui.initd b/sys-cluster/maui/files/maui.initd
new file mode 100644
index 000000000000..8c805619a184
--- /dev/null
+++ b/sys-cluster/maui/files/maui.initd
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/files/maui.initd,v 1.1 2011/06/29 13:55:09 alexxy Exp $
+
+. /etc/conf.d/torque
+PBS_SERVER_HOME="$(. /etc/env.d/25torque; echo ${PBS_SERVER_HOME})"
+
+depend() {
+ need net
+ after pbs_server
+ before pbs_mom
+ after logger
+}
+
+checkconfig() {
+ for i in "server_name"; do
+ if [ ! -e ${PBS_SERVER_HOME}/${i} ]; then
+ eerror "Missing config file ${PBS_SERVER_HOME}/${i}"
+ return 1
+ fi
+ done
+
+ if [ -z "$(grep 'queue_type' ${PBS_SERVER_HOME}/server_priv/queues/*)" ]; then
+ eerror "No queues have been defined yet."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Maui scheduler"
+ local extra_args=""
+
+ start-stop-daemon --start --exec /usr/sbin/maui
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Maui scheduler"
+ start-stop-daemon --stop -p /usr/spool/maui/maui.pid
+ eend ${?}
+}
+# vim:ts=4
diff --git a/sys-cluster/maui/maui-3.3.1.ebuild b/sys-cluster/maui/maui-3.3.1-r1.ebuild
index 947b0f5ff6bf..c348809d481f 100644
--- a/sys-cluster/maui/maui-3.3.1.ebuild
+++ b/sys-cluster/maui/maui-3.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1.ebuild,v 1.1 2011/03/05 10:29:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1-r1.ebuild,v 1.1 2011/06/29 13:55:09 alexxy Exp $
EAPI="3"
@@ -37,6 +37,7 @@ src_install() {
emake install BUILDROOT="${D}" INST_DIR="${ED}/usr" || die
dodoc docs/README CHANGELOG || die
dohtml docs/mauidocs.html || die
+ newinitd "${FILESDIR}/maui.initd" maui || die
}
pkg_nofetch() {